Closed Bug 984732 Opened 6 years ago Closed 6 years ago

homescreen icons have box around them

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: dietrich, Unassigned)

References

Details

(Keywords: regression)

Duplicate of this bug: 988529
Still seeing this on master (1.5), Nexus 4, built 3/24.
Any ideas Cristian?
Flags: needinfo?(crdlc)
Umm to be honest it is weird :) It seems that the code which is working wrong is here

https://github.com/mozilla-b2g/gaia/blob/master/apps/homescreen/js/page.js#L335

I can see in your screenshot that icon-able bookmarks work fine and the difference between app icons and icon-able bookmarks is when we create the canvas context. So it seems to be cause. Maybe a Gecko bug drawing images in a rect contexts with shadows?
Flags: needinfo?(crdlc)
I don't see this anymore -> WFM
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.