Closed Bug 984804 Opened 6 years ago Closed 6 years ago

Open All in Tabs not highlighted on keyboard selection; weak change on mouse-over

Categories

(Firefox :: General, defect)

x86_64
All
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: bj, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression, Whiteboard: [Australis:P3-])

Attachments

(1 file)

I regularly open all bookmarks with the keyboard, and recently I've lost the feedback that I've selected the correct entry.

With Nightly 31 (2014-03-17):
1) Click to open the Bookmarks popup.
2) With arrow keys move down to Show All Bookmarks.
3) Move the mouse over Show All Bookmarks.
4) With arrow keys move up to Recently Bookmarked, over, down to Open All in Tabs.
5) Move the mouse over Open All in Tabs.

Expected:
2&4) Visual difference in Show All Bookmarks/Open All in Tabs when selecting with arrow keys.
3&5) Visual difference when selecting with mouse.

Actual:
2&4) No noticeable change when select with the arrow keys.
3&5) Some difference when selecting with the mouse, but the difference is much less noticeable than the change on the other items in the menu.

Tested with Ubuntu and Windows. I tried an old install of 2014-03-07 and there was a difference in Open All in Tabs with keyboard activation.
Stephen, can we make the hover/focus state for the footers be more different from the plain state than it is now? I kind of agree that the change is very slight.

I need to look at the arrow keys issue, that's just kind of strange. :-\
Flags: needinfo?(shorlander)
Keywords: regression
Whiteboard: [Regression, Australis] → [Australis:P3-]
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8393239 [details] [diff] [review]
highlight footer more strongly, make it work for keyboard nav in the menu,

Stephen, does this change seem OK to you?
Attachment #8393239 - Flags: ui-review?(shorlander)
Flags: needinfo?(shorlander)
Comment on attachment 8393239 [details] [diff] [review]
highlight footer more strongly, make it work for keyboard nav in the menu,

Review of attachment 8393239 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks!
Attachment #8393239 - Flags: ui-review?(shorlander) → ui-review+
Comment on attachment 8393239 [details] [diff] [review]
highlight footer more strongly, make it work for keyboard nav in the menu,

LGTM too (Stephen's ui-r+ was most important here).
Attachment #8393239 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/72fadd2a164f
Keywords: access
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
Comment on attachment 8393239 [details] [diff] [review]
highlight footer more strongly, make it work for keyboard nav in the menu,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: bookmarks menu doesn't behave consistently when using the keyboard instead of the mouse, and its hover/active states are very hard to discern.
Testing completed (on m-c, etc.): soon on m-c!
Risk to taking this patch (and alternatives if risky): very low, CSS-only change to footers
String or IDL/UUID changes made by this patch: none
Attachment #8393239 - Flags: approval-mozilla-beta?
Attachment #8393239 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/72fadd2a164f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 31
Attachment #8393239 - Flags: approval-mozilla-beta?
Attachment #8393239 - Flags: approval-mozilla-beta+
Attachment #8393239 - Flags: approval-mozilla-aurora?
Attachment #8393239 - Flags: approval-mozilla-aurora+
Reproduced the issue using old Nightly (2014-03-17) on Windows 7 64bit and Windows 8.1 64bit. Verified as fixed on Firefox 29.0.1 RC, Firefox 30 beta 2 and latest Aurora.
You need to log in before you can comment on or make changes to this bug.