Closed Bug 984929 Opened 6 years ago Closed 6 years ago

'DevToolsExtensions.jsm - EXPORTED_SYMBOLS is not an array.' exception on b2g when opening the debugger

Categories

(DevTools :: Debugger, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(firefox30 fixed, firefox31 fixed)

RESOLVED FIXED
Firefox 31
Tracking Status
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

(Whiteboard: [needs-coverage])

Attachments

(1 file)

Typical regression on b2g, because of specific jsm behavior:
error occurred while processing 'attach: Error: resource://gre/modules/devtools/DevToolsExtensions.jsm - EXPORTED_SYMBOLS is not an array.

On b2g, all exported variables have to be set on `this`, otherwise it will just not work...
Attached patch Fix itSplinter Review
Whiteboard: [needs-coverage]
Attachment #8392899 - Flags: review?(evold)
Attachment #8392899 - Flags: review?(evold) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d58ec147e848
Assignee: nobody → poirot.alex
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Duplicate of this bug: 986863
Comment on attachment 8392899 [details] [diff] [review]
Fix it

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 964545
User impact if declined: no debugger
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch: none

Bug 964545 slipped into FF30, whereas this regression fix didn't.
We should uplift it to ensure having a working JS debugger when connecting to a 1.4 device or simulator.
Attachment #8392899 - Flags: approval-mozilla-aurora?
Attachment #8392899 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
OS: All → Gonk (Firefox OS)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.