Closed Bug 984969 Opened 6 years ago Closed 6 years ago

Delay Browser Toolbox connection until load event

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 31

People

(Reporter: jryans, Assigned: jryans)

References

Details

Attachments

(1 file)

The Browser Toolbox's main script file opens a connection at the top-level of the file[1].

This is okay currently, but in bug 797639, the transport will be refactored to use async streams, so this immediate connection dispatch stream events to the event queue.

The startup precompilation tool runs all these JS files, so this means it triggers the immediate connection here.  Once these future transport changes land, this tool ends up with event queue that causes it to segfault.

The easy fix is to just wait for load here, so the tool doesn't attempt network activity.

[1]: http://dxr.mozilla.org/mozilla-central/source/browser/devtools/framework/toolbox-process-window.js#25-32
Comment on attachment 8392952 [details] [diff] [review]
Only connect from Browser Toolbox after load

Review of attachment 8392952 [details] [diff] [review]:
-----------------------------------------------------------------

I'm secretly wishing this also fixes bug 945663.
Attachment #8392952 - Flags: review?(past) → review+
(In reply to Panos Astithas [:past] from comment #2)
> Comment on attachment 8392952 [details] [diff] [review]
> Only connect from Browser Toolbox after load
> 
> Review of attachment 8392952 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I'm secretly wishing this also fixes bug 945663.

That would be nice!  I can't reproduce that one, so maybe someone else will be able to tell if it's fixed...
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/198a62be50cf
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 31
QA Whiteboard: [qa-]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.