Closed Bug 985157 Opened 7 years ago Closed 7 years ago

[B2G][Marketplace][Calculator] Numbers on buttons are off-center

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 unaffected, b2g-v1.4 affected)

RESOLVED FIXED
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- affected

People

(Reporter: rpribble, Unassigned)

References

Details

(Keywords: regression, Whiteboard: dogfood1.4)

Attachments

(3 files)

Attached image v1.4Numbers.png
Description:
The numbers and characters are not centered on the buttons of the calculator as they have been previously, they are very low on the buttons.

Repro Steps:
1) Updated Buri to BuildID: 20140318000203
2) Tap marketplace
3) Search for and install the calculator app
4) Launch the calculator app
5) Observe the numbers very low on the buttons of the calculator

Actual:
Numbers on the calculator buttons are not centered.

Expected:
Numbers are centered as previously seen on v1.3.

Environmental Variables:
Device: Buri v1.4 MOZ ril
BuildID: 20140318000203
Gaia: c03a6af9028c4b74a84b5a98085bbb0c07261175
Gecko: 3776f72f1967
Version: 30.0a2
Firmware Version: v1.2-device.cfg

Notes: Unsure if this is a design choice.

Repro frequency: 100%
See attached: Screenshot
This issue does not occur on the Buri v1.3 MOZ ril.

Environmental Variables:
Device: Buri 1.3 MOZ ril
BuildID: 20140318004002
Gaia: 2ea2aab306bd1c941719160cdcb49ee9d755dc17
Gecko: cf2042938526
Version: 28.0
Firmware Version: V1.2-device.cfg

Numbers and characters on the buttons are centered.
Minor regression.
Component: General → Layout
Keywords: regression
Product: Firefox OS → Core
Version: unspecified → 30 Branch
Regression windows would not be a good idea in this case - it's a minor bug, which is too low of a priority to pursue a window against the cost of how long it takes to do a window (8 - 10 hours).

The app is here for the record - https://github.com/mozilla/Calculator.
This isn't 100% reduced, but it's close. You can see the difference by testing this on Desktop Firefox Beta vs. Desktop Firefox Nightly.
mats - is the test case in comment 4 reduced enough to go off of?
Flags: needinfo?(matspal)
I've also got a regression range down to a day so far:

3/13 - Working
3/14 - Busted

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=46041cc216fd&tochange=f073b3d6db1f
Given
  input { line-height: 6rem; }
in the testcase, most likely bug 349259.
Flags: needinfo?(matspal)
Blocks: 349259
I think the fix here is to fix the style sheet in question (probably by just removing the line-height declaration) -- we're honoring a style that we previously weren't honoring (and which other browsers honor).

(If the resulting problems were on major Web sites, I'd consider reverting the change, but in this case it should just be in the calculator code.)
(In reply to Timothy Nikkel (:tn) from comment #7)
> Given
>   input { line-height: 6rem; }
> in the testcase, most likely bug 349259.

Confirmed - removing this line of code causes us to get the same behavior on Firefox Beta & Nightly.
Where should bugs in the calculator app go?
Flags: needinfo?(poirot.alex)
Flags: needinfo?(dwalsh)
(In reply to David Baron [:dbaron] (needinfo? me) (UTC+8, but slow response this week) from comment #10)
> Where should bugs in the calculator app go?

Probably TE --> Preinstalled B2G Apps, given that this is a preinstalled app that isn't directly part of Gaia.
Component: Layout → Preinstalled B2G Apps
Flags: needinfo?(poirot.alex)
Flags: needinfo?(dwalsh)
Product: Core → Tech Evangelism
Version: 30 Branch → unspecified
Attachment #8393982 - Flags: review?(nick)
Thanks for the patch.  I'm getting caught up on a lot of work, but I'll test this patch out when I get a chance. Because this app is not in Gaia, just preloaded on a lot of devices, I will have to test this patch in 1.1.  It does not have the privilege of only having to support one version of Gaia like Gaia apps do. :P
Looks good, will push out an update to MP.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Attachment #8393982 - Flags: review?(nick) → review+
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.