Closed Bug 985184 Opened 6 years ago Closed 6 years ago

WebappsUpdateTimer.js not packaged with Fennec

Categories

(Firefox for Android :: Web Apps, defect, P1, blocker)

29 Branch
ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 + fixed
firefox30 + fixed
firefox31 --- fixed

People

(Reporter: myk, Assigned: myk)

Details

Attachments

(1 file)

The WebappsUpdateTimer.js component script isn't included in Fennec's package manifest, so it isn't being packaged with Fennec, and the update timer manager isn't able to trigger a periodic automatic update check.

The fix is obvious and trivial.  (And it begs the question why I didn't catch this in testing, where I'm sure I saw these timers fire, although now I don't see how I could have.)
Attachment #8393190 - Flags: review?(mark.finkle)
Severity: normal → blocker
Attachment #8393190 - Flags: review?(mark.finkle) → review+
Comment on attachment 8393190 [details] [diff] [review]
patch v1: obvious, trivial fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Bug 934760.

User impact if declined: 
  Fennec will not check for webapp updates automatically.

Testing completed (on m-c, etc.): 
  I tested this locally and have pushed it to inbound.

Risk to taking this patch (and alternatives if risky): 
  The risk is low, as it's a small, obvious patch.

String or IDL/UUID changes made by this patch:
  None
Attachment #8393190 - Flags: approval-mozilla-beta?
Attachment #8393190 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f3f8ffe30e2b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 29 → Firefox 31
Attachment #8393190 - Flags: approval-mozilla-beta?
Attachment #8393190 - Flags: approval-mozilla-beta+
Attachment #8393190 - Flags: approval-mozilla-aurora?
Attachment #8393190 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.