Closed Bug 985195 Opened 6 years ago Closed 6 years ago

WebappsUpdateTimer shares timer ID with nsUpdateService

Categories

(Firefox for Android :: Web Apps, defect, P1, blocker)

29 Branch
ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 + fixed
firefox30 + fixed
firefox31 --- fixed

People

(Reporter: myk, Assigned: myk)

Details

Attachments

(1 file)

The component manifest entry for WebappsUpdateTimer declares its ID to be "background-update-timer", which is the same ID as for nsUpdateService.  My reading of nsUpdateTimerManager.js suggests that this will cause one of them to replace the other in the manager's hash of timers, probably preventing the replaced one from being notified when the timer expires (and possibly causing other issues).

Here's the obvious fix: give WebappsUpdateTimer a unique ID.
Attachment #8393208 - Flags: review?(mark.finkle)
Attachment #8393208 - Flags: review?(mark.finkle) → review+
Comment on attachment 8393208 [details] [diff] [review]
patch v1: obvious fix

>+category update-timer WebappsUpdateTimer @mozilla.org/b2g/webapps-update-timer;1,getService,webapp-background-update-timer,browser.webapps.updateInterval,86400

I suppose the "b2g" part of the component ID is not a big deal
(In reply to Mark Finkle (:mfinkle) from comment #1)
> I suppose the "b2g" part of the component ID is not a big deal

I don't think so, but see bug 985295 for details on why and a patch that changes it anyway.
Comment on attachment 8393208 [details] [diff] [review]
patch v1: obvious fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  Bug 934760.

User impact if declined: 
  It's unclear, since this bug does not seem to have affected the update
  service's ability to check for updates on Nightly/Aurora.  But in theory
  it could interfere with that ability.  That presumably wouldn't matter on
  Beta, which we distribute via Google Play.  But it would matter on Aurora,
  and it feels safer to take the patch for Beta too.

Testing completed (on m-c, etc.): 
  I tested this locally and have pushed it to inbound.

Risk to taking this patch (and alternatives if risky): 
  The risk is low, as it's a small, obvious patch.

String or IDL/UUID changes made by this patch:
  None.
Attachment #8393208 - Flags: approval-mozilla-beta?
Attachment #8393208 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/bdfaed5b5ac4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 29 → Firefox 31
Attachment #8393208 - Flags: approval-mozilla-beta?
Attachment #8393208 - Flags: approval-mozilla-beta+
Attachment #8393208 - Flags: approval-mozilla-aurora?
Attachment #8393208 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.