Closed Bug 985333 Opened 6 years ago Closed 6 years ago

[Keyboard UX update][User Story] Default Upper case layout and typing hints

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.0)

RESOLVED FIXED
2.0 S1 (9may)
feature-b2g 2.0

People

(Reporter: bhuang, Assigned: rudyl)

References

Details

(Whiteboard: [ucid:SystemPlatform51, 2.0, ft:system-platform], [p=1])

Attachments

(1 file)

As a user, I want the hints that appear while I type to reflect the current case so I know what to expect when the input appears.

Acceptance:
Layout letters are in caps by default
Letter hints when typing reflect the current case (upper/lower case).

Refer to p.7 of UX spec in bug 983043
Isn't this a dup of bug 947558 ?  I guess this is a user story ?
Whiteboard: [ucid:SystemPlatform51, 1.5, ft:system-platform]
See bug 983043 for the UX spec update.
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #1)
> Isn't this a dup of bug 947558 ?  I guess this is a user story ?

Yes, this bug was opened as a user story.
Going to dupe that bug to this one.
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Duplicate of this bug: 947558
Target Milestone: --- → 1.4 S6 (25apr)
Attached file Patch V1 - pr 18569
I have a WIP here, but seems it would cause reflow.
Going to find an alternative way to show the case-sensitive pop-up.
Comment on attachment 8411636 [details] [review]
Patch V1 - pr 18569

Patch updated to put extra elements inside .visual-wrapper for uppercase/lowercase key popups.
These extra elements are added to avoid reflows if we changes "content: attr()" rule with different selectors.

Jan,

Could you please help review this?
Thank you.
Attachment #8411636 - Attachment description: WIP → Patch V1 - pr 18569
Attachment #8411636 - Flags: review?(janjongboom)
Target Milestone: 1.4 S6 (25apr) → 2.0 S1 (9may)
Whiteboard: [ucid:SystemPlatform51, 1.5, ft:system-platform] → [ucid:SystemPlatform51, 1.5, ft:system-platform], [p=1]
Whiteboard: [ucid:SystemPlatform51, 1.5, ft:system-platform], [p=1] → [ucid:SystemPlatform51, 2.0, ft:system-platform], [p=1]
Comment on attachment 8411636 [details] [review]
Patch V1 - pr 18569

Also ask for Tim's help to review this since Jan is not available recently.

Tim,

Could you help?
Thanks.
Attachment #8411636 - Flags: review?(timdream)
Comment on attachment 8411636 [details] [review]
Patch V1 - pr 18569

And need Omega to do ui review for this new feature.
Attachment #8411636 - Flags: ui-review?(ofeng)
Attachment #8411636 - Flags: ui-review?(ofeng) → ui-review+
Comment on attachment 8411636 [details] [review]
Patch V1 - pr 18569

I didn't read the CSS or verify the visual, please reflag review if I need to.

Also, do we have tests for IMERender?
Attachment #8411636 - Flags: review?(timdream) → review+
Unit test added for IMERender.

Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/c3f7b6a1692cc7d94d35002cc1d5aa236653e6d7

--
Thanks for the review.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Attachment #8411636 - Flags: review?(janjongboom)
feature-b2g: --- → 2.0
You need to log in before you can comment on or make changes to this bug.