Closed Bug 985417 Opened 7 years ago Closed 6 years ago

browser_net_simple-request-data.js | A promise chain failed to handle a rejection

Categories

(DevTools :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 33

People

(Reporter: Yoric, Assigned: vporof)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Once we land bug 976205, the following error will cause oranges.

04:47:41  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_simple-request-data.js | A promise chain failed to handle a rejection at chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_simple-init.js:78 - [object Object]
04:47:41     INFO -  Stack trace:
04:47:41     INFO -      test/</</<@chrome://mochitests/content/browser/browser/devtools/netmonitor/test/browser_net_simple-init.js:78:11
04:47:41     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:809:11
04:47:41     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:7

For testing, you may wish to import the patch of bug 976205.
This only happens after running browser_net_simple-init.js and is incorrectly reported as being caused by browser_net_simple-request-data.js
Attached patch v1Splinter Review
Going through try.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #8436339 - Flags: review?(dcamp)
Attachment #8436339 - Flags: review?(dcamp) → review+
https://hg.mozilla.org/mozilla-central/rev/6c12b36827e0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.