browser_scratchpad_reload_and_run.js | A promise chain failed to handle a rejection | TypeError: this.editor is null

RESOLVED FIXED in Firefox 33

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: Yoric, Assigned: past)

Tracking

(Blocks 1 bug)

unspecified
Firefox 33
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Once we land bug 976205, the following errors will cause oranges.

 TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/scratchpad/test/browser_scratchpad_reset_undo.js | A promise chain failed to handle a rejection at chrome://browser/content/devtools/scratchpad.js:497 - TypeError: this.editor is null
04:49:11     INFO -  Stack trace:
04:49:11     INFO -      SP_run/<@chrome://browser/content/devtools/scratchpad.js:497:9
04:49:11     INFO -  Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:809:11
04:49:11     INFO -  this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:688:7

For testing, you may wish to import the patch of bug 976205.
Blocks: 1016387
No longer blocks: 976205
Blocks: 1018184
No longer blocks: 1016387
I can no longer reproduce this with the patch from bug 1016387 applied. Tried both debug and opt builds with --run-until-failure.
Assignee: nobody → past
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Sigh. I can reproduce it again today, but it turns out that it's the previous test that causes the error, even though the harness reports it in browser_scratchpad_reset_undo.js. It is actually browser_scratchpad_reload_and_run.js that is the culprit. Will investigate further.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: browser_scratchpad_reset_undo.js | A promise chain failed to handle a rejection | TypeError: this.editor is null → browser_scratchpad_reload_and_run.js | A promise chain failed to handle a rejection | TypeError: this.editor is null
The previous comment is a bug in the bzpost hg extension, teh patch hasn't landed yet.
This fixes the error.
Now the patch landed, with the same cset ID.
https://hg.mozilla.org/mozilla-central/rev/ee11062f8966
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.