Closed Bug 985536 Opened 6 years ago Closed 6 years ago

Go back to allowing "optional any"

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox30 + fixed
firefox31 --- fixed

People

(Reporter: bzbarsky, Assigned: bzbarsky)

References

Details

Attachments

(2 files)

This is a partial backout of bug 970764.

The spec end is a bit in flux, but the current proposal is at http://lists.w3.org/Archives/Public/public-script-coord/2014JanMar/0176.html

Here's what I plan to implement for now, pending the spec getting sorted out:

1)  Support both "any" and "optional any".
2)  Treat "optional any" with no default value provided as having a default
    value of "undefined".

This means we won't be able to distinguish between "not passed" and "undefined" for "optional any", but that's OK.  This will also keep our pre-bug 970764 behavior of throwing if non-optional "any" is not passed.  That seems safer pending the spec getting sorted out.
Need to track this on 30 to make sure we fix it there.
Blocks: 970764
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attached patch Patch for AuroraSplinter Review
Comment on attachment 8401682 [details] [diff] [review]
Patch for Aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 970764 
User impact if declined: Some sites might start to depend on the behavior we
   have on Aurora right now, which we don't want.
Testing completed (on m-c, etc.): Passes tests.
Risk to taking this patch (and alternatives if risky): Low risk, I believe.
String or IDL/UUID changes made by this patch:  None.
Attachment #8401682 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/501baeb3a034
https://hg.mozilla.org/mozilla-central/rev/b44ac78a0298
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Attachment #8401682 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.