Closed Bug 985570 Opened 8 years ago Closed 8 years ago

[B2G][Youtube] The video will be cut off if the user goes fullscreen while in landscape and switches back to portrait view

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected)

RESOLVED FIXED
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected

People

(Reporter: demerick, Assigned: fzzzy)

References

Details

(Whiteboard: dogfood1.4)

Attachments

(2 files)

Attached file logcat.txt
Description:
If the user views a video in fullscreen while in landscape view and then switches to portrait mode and exits fullscreen the video will be cut off.

Repro Steps:
1) Update a Buri to BuildID: 20140319000200
2) Download the Youtube app from the marketplace
3) Launch the Youtube app from the home screen
4) Tap on any video
5) Change the orientation of the screen to enter landscape
6) Tap 'Play' and then tap the video and tap the 4 arrows in the controls to enter full screen
7) Change the orientation of the screen to enter portrait 
8) Tap the video and tap the 4 arrows to exit full screen

Actual:
The user will not be able to see the whole video

Expected:
The whole video should display correctly

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140319000200
Gaia: c03a6af9028c4b74a84b5a98085bbb0c07261175
Gecko: b07ecc057abf
Version: 30.0a2
Firmware Version: v1.2-device.cfg

Notes:
This reproduces in the youtube app from the marketplace, the youtube app from E.me, and the youtube mobile website.

Repro frequency: 100%
See attached: logcat, screenshot
This issue also occurs on the Buri v 1.3.0 Mozilla RIL

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140319004003
Gaia: f2f2be55dcca1d6775592ef478948045935a91ed
Gecko: 87d90ecfe616
Version: 28.0
Firmware Version: v1.2-device.cfg

Watching a video on youtube in landscape/fullscreen then switching to portrait and leaving fullscreen will cutoff the video.
This issue also occurs on the Buri v 1.1.0 Mozilla RIL

1.1 Environmental Variables:
Device: Buri 1.1 MOZ
BuildID: 20140318041202
Gaia: 44a2ddf63373f8e95c784faf4ed4d60081699c61
Gecko: 2c70ef07c5b3
Version: 18.0
Firmware Version: v1.2-device.cfg
Please review and provide a potential fix date.  Thank you.
Assignee: nobody → dpreston
Status: NEW → ASSIGNED
Priority: -- → P1
Flags: needinfo?(dpreston)
Hi all, I've tested on OPENC (build:20140325120432) and I cannot reproduce it. Can anyone check it out?
Jose, which branch did you test? I will test this.
Flags: needinfo?(dpreston)
Hi Donovan.

Sorry, I can't access the Gecko branch number but I can provide you with
Build date: march 25 2014 
Build number: 20140325100432
Gaia Commit: 2014-03-21 07:16:57 (0cddd1cc)
Tested on Buri v1.3 and not reproducible. can anyone confirm this so we can close this bug?
Nicole, could you test this bug on a Buri, if you can find one Buri, and see if you can reproduce it? If you can not reproduce, then we can close this bug. 

Donovan already tested this on a Flame device, and can not reproduce it.
Flags: needinfo?(nfong)
Unable to reproduce on Buri.  Changing to Resolved - Fixed.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: needinfo?(nfong)
Resolution: --- → FIXED
I'm not able to reproduce either. Closed
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.