Closed Bug 985681 Opened 6 years ago Closed 6 years ago

Camcorder crash when recording video for more than 5 minutes

Categories

(Core :: Graphics: Layers, defect, critical)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 988713
blocking-b2g 1.4+

People

(Reporter: ggrisco, Assigned: sotaro)

References

Details

(Keywords: crash, Whiteboard: [CR 634279][b2g-crash])

Crash Data

Attachments

(2 files)

1.open Camera app and switch to camcorder
2.Start recording
3.Try to record the video for more than 5 minutes

Crash occurs with crash signature:

[@ jemalloc_crash | arena_dalloc | mozilla::layers::TextureChild::~TextureChild() | mozilla::detail::RefCounted<mozilla::layers::TextureChild, (mozilla::detail::RefCountAtomicity)0>::Release() const ]

Have seen this at least 5 times
Attached file EXTRA file attachment
Sotaro, any idea what might be going on here?
Flags: needinfo?(sotaro.ikeda.g)
blocking-b2g: --- → 1.4?
Component: General → Graphics: Layers
Keywords: crash
Product: Firefox OS → Core
Whiteboard: [CR 634279] → [CR 634279][b2g-crash]
Version: unspecified → 30 Branch
blocking-b2g: 1.4? → 1.4+
attachment 8393761 [details] seems like double delete, but TextureChild is already thread safe ref couneted. Hmm.
Flags: needinfo?(sotaro.ikeda.g)
Assignee: nobody → sotaro.ikeda.g
(In reply to Greg Grisco from comment #0)
> [@ jemalloc_crash | arena_dalloc |
> mozilla::layers::TextureChild::~TextureChild() |
> mozilla::detail::RefCounted<mozilla::layers::TextureChild,
> (mozilla::detail::RefCountAtomicity)0>::Release() const ]
> 
> Have seen this at least 5 times

Greg, how often does it happen? Which device did you test?
Flags: needinfo?(ggrisco)
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> Greg, how often does it happen? Which device did you test?

We have seen it exactly 5 times all on the same build.  This was on Madai device.
Flags: needinfo?(ggrisco)
Sorry, I used the wrong terminology.  This is on QRD8x26.
Bug 985878 might causing the problem.
Depends on: 985878
Greg, can you test again by applying attachment 8394044 [details] [diff] [review] in Bug 985878?
Flags: needinfo?(ggrisco)
(In reply to Greg Grisco from comment #5)
> (In reply to Sotaro Ikeda [:sotaro] from comment #4)
> > Greg, how often does it happen? Which device did you test?
> 
> We have seen it exactly 5 times all on the same build.  This was on Madai
> device.

Sorry, I just want to know the frequency(how often), not the number of the crash. Can you tell the frequency of the crash (like 5/20)?
The tester who reported says every time he is able to reproduce.  I was able to record from 5-10 minutes without seeing the crash, so I am asking for re-test right now.  I'll report the findings when I hear back.
We couldn't reproduce it, so closing for now.  Will reopen if it happens again.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(ggrisco)
Resolution: --- → WORKSFORME
We are seeing this multiple times now, latest using:

gaia sha1:  7e705dd4718d528974d99ac31866318d7e201152
gecko sha1: 81826931597f4b330cf2d6c40f444bcce000a6b8
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Greg, is there some way to narrow the STR? Recording settings, etc? I've got a Nexus 4 here happily into its 10th minute of video recording with no signs of slowing down.

- gecko: b2g-inbound:a4ac15d6912d
- gaia: master:c8e974e69c764b953263c7474d10c25aa68bb862

AFAIK, the camera still isn't working on our QRD devices, so the CAF team may have to take the lead on tracking this one down.
Upon talking to QC the expectation is that we work off of the mini dump. Is that possible for you to check?
Flags: needinfo?(mhabicher)
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
> Greg, can you test again by applying attachment 8394044 [details] [diff] [review]
> [review] in Bug 985878?

Bug 988713 might also related.
(In reply to Mike Habicher [:mikeh] from comment #13)
> Greg, is there some way to narrow the STR? Recording settings, etc? I've got
> a Nexus 4 here happily into its 10th minute of video recording with no signs
> of slowing down.
> 
> - gecko: b2g-inbound:a4ac15d6912d
> - gaia: master:c8e974e69c764b953263c7474d10c25aa68bb862
> 
> AFAIK, the camera still isn't working on our QRD devices, so the CAF team
> may have to take the lead on tracking this one down.

the tests that we are running are,

Run gaia-ui test script with camera, camcorder, Music, Video and FM test cases sequentially
> AFAIK, the camera still isn't working on our QRD devices, so the CAF team
> may have to take the lead on tracking this one down.

@mikeh: Camera issue is fixed on the QRD build, hopefully that will help expedite the investigation here.
Sotaro, anything actionable for you on this one, or are you blocked on something or somebody else?
Flags: needinfo?(sotaro.ikeda.g)
I am checking if QRD device works. Right now, camera preview works, but failed to start recording. I am investigating about it.
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Milan Sreckovic [:milan] from comment #18)
> Sotaro, anything actionable for you on this one, or are you blocked on
> something or somebody else?

Camera becomes partially works on QRD device, but the recording still does not work. I am asking about it to codeaurora.
Bug 988713 is not uplifted to b2g v1.4 yet.
Depends on: 988713
Greg, can you confirm if attachment 8399258 [details] [diff] [review] in Bug 988713 could fix the problem?
Flags: needinfo?(ggrisco)
Tapas, can you please check this please.
Flags: needinfo?(ggrisco) → needinfo?(tkundu)
(In reply to Inder from comment #23)
> Tapas, can you please check this please.

I didn't see it in my manual testing in tip of v1.4. But this issue happens randomly. So, I asked our internal test team to confirm this . I will update here once they confirm me.
On QRD8x26 device, camera recording still does not work. I can not test the problem on my side.
From attachment 8393762 [details], TextureChild::~TextureChild() causes the SIGSEGV by accessing 0x0 address, therefore TextureChild's double delete seems happen. But TextureChild is thread safe reference counted.

> Crash reason:  SIGSEGV
> Crash address: 0x0
AtomicRefCounted<>'s thread safety problem was fixed by Bug 985878 on 2014-03-26 on mozilla hg.
 Race condition when destroying TextureClient & TextureChild(Bug 988713) was uplifted to b2g v1.4 on 2014-04-09 on mozilla hg.
(In reply to Tapas Kumar Kundu from comment #24)
> (In reply to Inder from comment #23)
> > Tapas, can you please check this please.
> 
> I didn't see it in my manual testing in tip of v1.4. But this issue happens
> randomly. So, I asked our internal test team to confirm this . I will update
> here once they confirm me.

If the crash becomes very rare, it might be Bug 994903.
Flags: needinfo?(mhabicher)
It didn't come in latest stability run. But I will wait to see results for another test run as it happens randomly. I will confirm here once I get results from another run.
Tapas, if there is a crash, please attach the new crash log. Thanks.
(In reply to Sotaro Ikeda [:sotaro] from comment #30)
> Tapas, if there is a crash, please attach the new crash log. Thanks.

We are not seeing it with latest gaia/gecko. It seems like it is fixed.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(tkundu)
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 988713
You need to log in before you can comment on or make changes to this bug.