Closed Bug 985851 Opened 8 years ago Closed 4 years ago

[Keyboard UX update][User Story] Add settings shortcut to the IME selector

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P1)

x86
Gonk (Firefox OS)
defect

Tracking

(tracking-b2g:+)

RESOLVED WONTFIX
tracking-b2g +

People

(Reporter: bhuang, Unassigned)

References

Details

(Whiteboard: [ucid:SystemPlatform54, 2.0, ft:system-platform][2.5-aries-test-run-3])

As a user, I want to be able to navigate to settings in the IME selection menu in case the keyboard I want to use is not in the list.

Acceptance:
Long press IME key to show selector menu.
Selector menu should have a button that sends users to (Settings > Keyboard)

Refer to p.8 of UX spec in bug 983043
Whiteboard: [ucid:SystemPlatform54, 1.5, ft:system-platform]
See bug 983043 for the UX spec update.
Whiteboard: [ucid:SystemPlatform54, 1.5, ft:system-platform] → [ucid:SystemPlatform54, 1.5, ft:system-platform], [p=1]
Target Milestone: --- → 2.0 S1 (9may)
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Whiteboard: [ucid:SystemPlatform54, 1.5, ft:system-platform], [p=1] → [ucid:SystemPlatform54, 2.0, ft:system-platform], [p=1]
Need to address an issue stated in bug 1003649 comment 7.
> 4) In "Settings > Keyboards", the top-left icon is "X" (it's correct). Tap
> "Built-in Keyboard" -> Tap "<" to go back -> the "X" in "Settings >
> Keyboards" change to "<" -> KO
>    It should keep "X".
Depends on: 1005827
Whiteboard: [ucid:SystemPlatform54, 2.0, ft:system-platform], [p=1] → [ucid:SystemPlatform54, 2.0, ft:system-platform], [p=2]
Target Milestone: 2.0 S1 (9may) → 2.0 S2 (23may)
Set the dependency according to  bug 1003649 comment 7.

> 3) When tapping "Settings" in value selector first time, it goes to
> "Settings" and then goes to "Keyboards"
>    It should go to "Keyboards" directly.
Depends on: 1007600
feature-b2g: --- → 2.0
feature-b2g: 2.0 → ---
Depends on: 1013837
Target Milestone: 2.0 S2 (23may) → ---
No longer depends on: 1013837
Unassign myself from this user story bug, still need to get those 2 dependent bugs fixed to accomplish this user story.
Assignee: rlu → nobody
Whiteboard: [ucid:SystemPlatform54, 2.0, ft:system-platform], [p=2] → [ucid:SystemPlatform54, 2.0, ft:system-platform]
Priority: -- → P1
Status: ASSIGNED → NEW
Test case was added by William:

https://moztrap.mozilla.org/manage/case/12881/
QA Whiteboard: [QAnalyst-Triage+]
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Let's make a decision on whether or not this should reach 2.2.
feature-b2g: --- → 2.2?
blocking-b2g: --- → backlog
feature-b2g: 2.2? → ---
tracking-b2g: --- → +
Duplicate of this bug: 1111511
blocking-b2g: backlog → ---
Whiteboard: [ucid:SystemPlatform54, 2.0, ft:system-platform] → [ucid:SystemPlatform54, 2.0, ft:system-platform][2.5-aries-test-run-3]
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.