Closed Bug 985917 Opened 7 years ago Closed 7 years ago

[webvtt] Two rows subtitles are not entirely visible when browser is in fullscreen

Categories

(Core :: Audio/Video, defect)

29 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox31 --- unaffected

People

(Reporter: phorea, Assigned: reyre)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Reproducible on latest Firefox 29 beta 1 (20140318013849). 
Not reproducible on latest Aurora 30.0a2 (20140319004002) where the subtitles size is not modified and latest Nightly 31.0a1 (20140319030201) where the subtitles are missing.

Steps to reproduce:
1. Open the link with the demo video: http://rickeyre.ca/2013/06/20/webvtt-cycle-collector-demo.html while the browser is windowed mode
2. Start the video
3. Maximize the browser to full screen
4. Check the subtitles when displayed in two rows

Actual results:
The subtitles second row is not entirely visible. Please see the screenshot.

Expected results:
The subtitle area should be placed above the controls when the video is played inline (just as they are when video is played full screen)

Notes:
1. Reproducible also on Mac OS X 10.8 and Ubuntu 32-bit.
2. The issue was introduced in Firefox 29 when the feature landed, so it's not a regression. Will continue investigate to see when it was introduced.
Attached image vtt subtitle.jpg
Thanks for catching this Petruta. I thought I landed the patch to fix that in time for FF29, but I guess not.

The easiest way to fix this would be to land Part 8 and 9 of the patches in bug 865407. 1 - 7 made it in to FF29, but 8 and 9 didn't which is causing this.
Assignee: nobody → rick.eyre
I'm closing this since we're not turning the pref on until 31 and it's been fixed there.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.