History older than 6 months is not synced

VERIFIED INVALID

Status

()

defect
VERIFIED INVALID
5 years ago
7 months ago

People

(Reporter: avaida, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Pre-requisites:
- a dirty profile with browsing history dating back to 6 months ago

This issue is reproducible with the latest Beta (Build ID: 20140318013849) [1], all the platforms.

Steps to reproduce:
1. Launch Firefox with a dirty profile.
2. Click on the menu button and select "Sign in to Sync".
3. Choose "Get Started" and then create a new Firefox Account.
4. Sign in with your newly created Firefox account.
5. Make sure that Options > Sync menu has all the available data types checked for syncing.
6. Browse through a couple of websites.
7. Launch Firefox with a different profile and sign-in with the same Firefox Account.
8. Access History on the 2nd profile and see if it synced with the 1st profile.

Expected result:
The history from the 2nd profile should display the same data as the history from the 1st profile.

Actual result:
The history older than 6 months is not synced on the 2nd profile, while the more recent history (i.e. today, yesterday, 7 days ago) is synced.

I will follow up on this bug later today, with further details.


1. Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
We only sync 5,000 history items.
Component: Server: Sync → Firefox Sync: Backend
Isn't there also a ttl? In the past, I've tried to save huge history/bookmark accounts with sync, only to have the history disappear attempting to retrieve the data several months later.
this could also be supported by this bug 981836
There's a 60-day TTL on history items, but that would require a 60-day gap between steps 5 and 6 :)
(Reporter)

Comment 5

5 years ago
(In reply to Richard Newman [:rnewman] from comment #1)
> We only sync 5,000 history items.
The history available on the dirty profile I used was less than 5,000 items.

(In reply to Richard Newman [:rnewman] from comment #4)
> There's a 60-day TTL on history items, but that would require a 60-day gap
> between steps 5 and 6 :)
The profile I used only had browsing history older than 6 months, so the history created at step 6 was added under "Today". I tried using a different profile afterwards (dirty as well), with more recent history (last month, two months ago, last week, yesterday) and the data synced properly on other profiles.

Please let me know if I understood this correctly, Richard: if I have a profile with history that has not been synced for a long time ( > 60 days) and I attempt to sync it now with another profile/device, that data should not appear due to the 60-day TTL?
Flags: needinfo?(rnewman)
There are three things going on here. You're probably seeing #2.

Firstly, the TTL. If you synced a client more than 60 days ago, any history items uploaded at that time won't be downloaded by new devices. The TTL applies to the server, not the client.

So:

1. In 2013, do some browsing.
2. Set up Sync.
3. Wait 60+ days.
4. Do more browsing.
5. Connect another device.

The other device will see only the history added in 4, not in 1.


Secondly, there's a cutoff date embedded in the desktop history client. It won't 'see' history older than 30 days. This stands out in the code:

  getAllIDs: function HistStore_getAllIDs() {
    // Only get places visited within the last 30 days (30*24*60*60*1000ms)
    this._allUrlStm.params.cutoff_date = (Date.now() - 2592000000) * 1000;

So:

1. In February or earlier, do some browsing.
2. Set up Sync.
3. Do some browsing.
4. Connect another device.

The other device will see only the history added in 3, not in 1.


Thirdly, we limit the number of records uploaded. Anything excluded from that initial batch of 5,000 won't ever be synced.


As such, I think you're seeing expected behavior.
Flags: needinfo?(rnewman)
(Reporter)

Comment 7

5 years ago
Thank you for clarifying this, Richard, this seems to be indeed the expected behavior in the case of my profile. Closing this issue as invalid.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 months ago
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.