Closed Bug 985964 Opened 7 years ago Closed 7 years ago

No 2.27a2 aurora nightly builds since the last merge

Categories

(SeaMonkey :: Build Config, defect)

SeaMonkey 2.27 Branch
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rsx11m.pub, Assigned: ewong)

References

Details

Attachments

(1 file)

I think we had this in previous cycles before - aurora builds aren't started any more for all platforms, the last builds were March 17 just before the merge.

There are no folders or log files on the FTP server. Trunk (except Linux) nightly and beta tinderbox builds seem ok.
We're getting this on OSX64:

checking for localeconv... (cached) yes
updating cache /builds/slave/c-aurora-osx64-ntly/build/objdir/i386/config.cache
creating ./config.status
Reticulating splines...
Traceback (most recent call last):
  File "./config.status", line 916, in <module>
    config_status(**args)
  File "/builds/slave/c-aurora-osx64-ntly/build/mozilla/python/mozbuild/mozbuild/config_status.py", line 148, in config_status
    summary = the_backend.consume(definitions)
  File "/builds/slave/c-aurora-osx64-ntly/build/mozilla/python/mozbuild/mozbuild/backend/base.py", line 186, in consume
    for obj in objs:
  File "/builds/slave/c-aurora-osx64-ntly/build/mozilla/python/mozbuild/mozbuild/frontend/emitter.py", line 106, in emit
    objs = list(self.emit_from_sandbox(out))
  File "/builds/slave/c-aurora-osx64-ntly/build/mozilla/python/mozbuild/mozbuild/frontend/emitter.py", line 433, in emit_from_sandbox
    sandbox['SRCDIR'])
mozbuild.frontend.reader.SandboxValidationError: A jar.mn exists in /builds/slave/c-aurora-osx64-ntly/build/mozilla/extensions/venkman/resources but it is not referenced in the corresponding moz.build file. Please define JAR_MANIFESTS in the moz.build file.
configure: error: /builds/slave/c-aurora-osx64-ntly/build/mozilla/configure failed for mozilla
*** Fix above errors and then restart with               "make -f client.mk build"
make[2]: *** [configure] Error 1
make[1]: *** [objdir/i386/Makefile] Error 2
make: *** [build] Error 2
program finished with exit code 2
elapsedTime=68.317676

Ditto with Win32.  Linux is because of libpango version.
> mozbuild.frontend.reader.SandboxValidationError: A jar.mn exists in
> /builds/slave/c-aurora-osx64-ntly/build/mozilla/extensions/venkman/resources
> but it is not referenced in the corresponding moz.build file. Please define
> JAR_MANIFESTS in the moz.build file.

I fixed ths in Bug 952120 (Port bug 774572 (Define JAR_MANIFESTS in moz.build files) to Venkman). Don't know why the build scripts are picking an older changeset of Venkman.
client.py  in Aurora is supposed to be pulling Venkman using the SEA2_25_RELBRANCH tag And that branch has my fix.
Duplicate of this bug: 987858
Pushed already to comm-aurora (r+a=bustage)
Putting the patch on here for post-push review.
Attachment #8397637 - Flags: review?(bugspam.Callek)
I see recent tinderbox builds for Windows and Mac OSX, this seems to have done the trick.
So, this will have to be done after each merge now or is there some way to automate it?
Attachment #8397637 - Flags: review?(bugspam.Callek) → review+
I believe this is fixed.
Assignee: nobody → ewong
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.