Closed Bug 986146 Opened 7 years ago Closed 6 years ago

Firefox 29.0 Crash Report [@ nvwgf2um.dll@0x6fdd1f ]

Categories

(Core :: Graphics, defect)

29 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox29 + verified
firefox30 + verified
firefox31 --- verified

People

(Reporter: bytehead, Assigned: mattwoodrow)

References

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140319030201

Steps to reproduce:

Running my game (Tiberium Alliances) at https://prodgame05.alliances.commandandconquer.com/14/index.aspx

Wait about 30-60 seconds after logging in.

This game has had no issues, up until I updated my beta to the 29.0 branch.  In fact, the release version that I am running is not having any issues, either.  I run two accounts, so I need two different browsers.  

I have NOT tried running the game under Nightly in over a year.  Nightly is what I am using to report this, FWIW.


Actual results:

Crashes.

https://crash-stats.mozilla.com/report/index/0bb98d6a-6811-45b3-b5c6-685012140320
https://crash-stats.mozilla.com/report/index/6c1c362d-b56a-417f-857c-5fba92140320

Maybe this is related to the other nVidia bugs that I've seen as I researched this bug, but the address is different.  And I don't know if the address is significant or not.  If it's a dupe, it's a dupe.


Expected results:

Should not crash.
Crash Signature: [@ nvwgf2um.dll@0x6fdd1f ]
Is there a way to create a test account?
Flags: needinfo?(bytehead)
I can give you access to my second account, but I'd rather not give out that information over a public forum.  I'll shoot you an email with the details.  That particular server has maxxed out the number of users on it.  Other servers may be the same, but I figure using the same server will keep things simpler for this issue.

I DID try this in safemode, and I didn't run into this, or at least it sat for 15 minutes without blowing up, but to make this game playable, you have to have at least Greasemonkey and some scripts running.  Thinking about this, I'll disable everything but Greasemonkey and see if I still run into the issue.  I suspect so.

I'll comment back once I have that profile set.
Flags: needinfo?(bytehead)
And... Boom!  I was attacking another camp, and it went teats/toes up.

https://crash-stats.mozilla.com/report/index/bp-e25adcaf-37e8-4152-bb8b-5696d2140321

And a couple of more, actually.

So far, I have NOT seen a crash in safe mode.  Although if I have Greasemonkey loaded -- but NOT running any scripts!, it will crash, generally while attacking or preparing to attack another camp.

I'm sitting with it in the background, so we'll see if it actually happens or not.

Maybe I need to create a new profile with only Greasemonkey loaded to see if that continues to happen, and isn't something that's a holdover from the current profile.  Later this evening when I have more time.
Thank you, Bryan.
I received the account info via email.
I confirm the crash on nightly 31.0a1 (2014-03-23), Win 7 x64 when attacking another camp.
I've tried on a new profile, without Greasemonkey installed.
https://crash-stats.mozilla.com/report/index/26cbc998-434d-4a7c-9112-a1c5c2140324
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics
Ever confirmed: true
Product: Firefox → Core
This might be a case of bug 988548, but here we seem to have steps to reproduce, thanks!
Fermi GPUs(GF400/500) have known crash issues with drivers older than 332.21.

"[Fermi-class GPU]: Browser freezes and crashes. [1358403]"

Try updating your drivers to the latest Nvidia drivers and see if they fix this.

http://www.geforce.com/whats-new/articles/nvidia-geforce-335-23-whql-titanfall-drivers
"Try updating your drivers to the latest Nvidia drivers and see if they fix this."

Hahahahahahaha!  No!

Running 335.23 and...

https://crash-stats.mozilla.com/report/index/1440fb8b-b029-4bd7-916a-1e3ff2140329

Although this crash points at bug 988548, which Robert has already pointed out may be a related case, and must be since the signature has changed.

And yes, I'm laughing (or crying), it takes too long to reboot.  I really, really need to change it so that I don't have box, dropbox, gdrive, tresorit (strike that, just uninstall that one), onedrive and other startup programs starting at the same time.  Once it's running, I don't mind it.  Reboots are killers.
Judging from the stack traces in the crashes, this is bug 988548, which probably can be fixed with the patch in bug 973264 - but that one is somewhat risky for beta. If it's that, it's probably not an NVidia driver issue specifically, as we have a lot of such crashes with Intel graphics as well.
Can you please test if current Nightly builds exhibit the same crash? If not, please let us know as that means that the bug 973264 patch seems to work.
Oh, I see this didn't land on Nightly yet. :(

We still need to wait until it does.
Bug 973264 has landed in Nightly now - Bryan, can you test with a current Nightly if this crash still happens?
The fix will be in the Beta we ship later this week, but any testing earlier is welcome.
Flags: needinfo?(bytehead)
OK, Robert.  I have used my Nightly to attack multiple camps, complete with Greasemonkey scripts, and I didn't get any crashes, so I have to assume that the bug is fixed.

Thanks!
Flags: needinfo?(bytehead)
(In reply to Bryan Price from comment #11)
> OK, Robert.  I have used my Nightly to attack multiple camps, complete with
> Greasemonkey scripts, and I didn't get any crashes, so I have to assume that
> the bug is fixed.

OK, given that, I'll mark this one fixed on trunk, thanks for your testing!

If you could also test the beta that's coming later this week, we'll be also able to close it out for 29. :)
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: crash
Resolution: --- → FIXED
I certainly will.  I would like to get back to the way things were running before this bug bit me.

That means, running one of my games on the beta!
Assignee: nobody → matt.woodrow
Depends on: 973264
Target Milestone: --- → mozilla31
Reproduced in FF 29b4.
No crash in FF 29b5, 30.0a2 (2014-04-03), Win 7 x64.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Yep.  Updated the beta, and I no longer crash.

Thanks!
(In reply to Bryan Price from comment #16)
> Yep.  Updated the beta, and I no longer crash.
> 
> Thanks!

That's awesome, thanks for reporting and testing!
You need to log in before you can comment on or make changes to this bug.