Closed Bug 986147 Opened 6 years ago Closed 6 years ago

[GGC] On Maple jsreftests: Assertion failure: !(*thingp)->arenaHeader()->allocatedDuringIncremental

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: sfink, Assigned: terrence)

References

Details

Attachments

(1 file)

See eg https://tbpl.mozilla.org/?tree=Maple&rev=8fe4b56c9537

Mostly happens on Windows, but OSX got it too. Logs:

https://tbpl.mozilla.org/php/getParsedLog.php?id=36458897&tree=Maple
https://tbpl.mozilla.org/php/getParsedLog.php?id=36462268&tree=Maple
https://tbpl.mozilla.org/php/getParsedLog.php?id=36461005&tree=Maple
https://tbpl.mozilla.org/php/getParsedLog.php?id=36461220&tree=Maple

Error:

INFO -  Assertion failure: !(*thingp)->arenaHeader()->allocatedDuringIncremental, at /builds/slave/map-osx64-d-000000000000000000/build/js/src/gc/Marking.cpp:364
WARNING -  TEST-UNEXPECTED-FAIL | file:///builds/slave/talos-slave/test/build/tests/jsreftest/tests/jsreftest.html?test=ecma_6/Math/atanh-approx.js | Exited with code 1 during test run

0  XUL!js::gc::IsAboutToBeFinalized<js::ArrayBufferViewObject> [Marking.cpp:8fe4b56c9537 : 339 + 0x0]
1  XUL!js::gc::IsObjectAboutToBeFinalized(js::ArrayBufferViewObject**) [Marking.cpp:8fe4b56c9537 : 459 + 0x4]
2  XUL!js::ArrayBufferObject::sweep(JSCompartment*) [ArrayBufferObject.cpp:8fe4b56c9537 : 820 + 0x4]
3  XUL!js::Nursery::collect(JSRuntime*, JS::gcreason::Reason, js::Vector<js::types::TypeObject*, 0ul, js::SystemAllocPolicy>*) [Nursery.cpp:8fe4b56c9537 : 769 + 0x7]
4  XUL!Collect [jsgc.cpp:8fe4b56c9537 : 5102 + 0x12]
5  XUL!nsJSContext::GarbageCollectNow(JS::gcreason::Reason, nsJSContext::IsIncremental, nsJSContext::IsCompartment, nsJSContext::IsShrinking, long long) [nsJSEnvironment.cpp:8fe4b56c9537 : 1850 + 0x11]
6  XUL!nsTimerImpl::Fire() [nsTimerImpl.cpp:8fe4b56c9537 : 551 + 0x9]
r=sfink via IRC.
Assignee: nobody → terrence
Status: NEW → ASSIGNED
Attachment #8394411 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/f7cc3196d216
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Duplicate of this bug: 987467
You need to log in before you can comment on or make changes to this bug.