Closed Bug 986473 Opened 7 years ago Closed 7 years ago

Modify cost control parameters

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 verified)

VERIFIED FIXED
1.4 S4 (28mar)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- verified

People

(Reporter: brg, Assigned: mai)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
salva
: review+
Details | Review
After local testing in the target country the cost control feature, there is a need to change the automatic check for the balance to only manual.

The main reason to ask for this last minute change it is because we cannot guarantee that this automatic check is free. 

We had not launch 1.3 in those countries yet so we are on time to make the fix available to all the customers.

Change the flag: is_free and is_roaming_free from true to false.
- For Colombia, line 5 and line 6 at: https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/costcontrol/js/config/movistar_colombia/config.js
- For Peru(only is_free), line 5 at: https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/costcontrol/js/config/movistar_peru/config.js
- For Uruguay, line 6 and 7 at: https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/costcontrol/js/config/movistar_uruguay/config.js
Is these target markets for 1.3?
Flags: needinfo?(brg)
(In reply to Preeti Raghunath(:Preeti) from comment #1)
> Is these target markets for 1.3?

Looks like it.

* https://mana.mozilla.org/wiki/display/PM/Go-to-Market
* https://intranet.mozilla.org/Program_Management/Firefox_OS/WeeklyStatus/TCL
Flags: needinfo?(brg)
blocking-b2g: 1.3? → 1.3+
Attached file patch v1.0
Salva, could you review the patch?

Regards
Attachment #8395187 - Flags: review?(salva)
Assignee: nobody → mri
Comment on attachment 8395187 [details] [review]
patch v1.0

No risky changes. Thank you.
Attachment #8395187 - Flags: review?(salva) → review+
Target Milestone: --- → 1.4 S4 (28mar)
Master: 5658a196397c6a17d2d882ae8471bf95f0315cc6
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8395187 [details] [review]
patch v1.0

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.
Change into configuration parameters to deactivate the automatic balance actualization
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: the possibility of extra charges on the user billing account.
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): No risk
[String changes made]:No
Attachment #8395187 - Flags: approval-gaia-v1.3?(fabrice)
Attachment #8395187 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3?(release-mgmt)
(In reply to marina rodríguez [:mai] from comment #6)
> Comment on attachment 8395187 [details] [review]
> patch v1.0
> 
> NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> better understand the B2G approval process and landings.
> Change into configuration parameters to deactivate the automatic balance
> actualization
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): Feature
> [User impact] if declined: the possibility of extra charges on the user
> billing account.
> [Testing completed]: Yes
> [Risk to taking this patch] (and alternatives if risky): No risk
> [String changes made]:No

:Its too late to add a feature at this stage, is this a regression or a fallout from cost control stages ?
If not, its unclear why exactly this is needed now. Is see the user impact is bad but has this always been the case ?

Also don't see any automated testscases on the patch, do we have existing test coverage in this area of code. I checked with mozilla QA and they said tef would be in the best position to verify this on on master and ensure no fallouts are seen. Can you confirm this is on your radar for verification ? may be Massimo and Lolican help here.
Flags: needinfo?(mri)
Hi,
  the files of the folder 'costcontrol/js/config' are specific implementations of the costcontrol configuration, for this reason is not necessary make tests for each one of them. The global config tests are implemented on the test file 'costcontrol/test/unit/vivo_config.js'. 

On this bug, we are changed the behavior of the costcontrol app for an specific mcc/mnc, not the general behaviour of the app.

Regards
Flags: needinfo?(mri)
(In reply to bhavana bajaj [:bajaj] from comment #7)
> (In reply to marina rodríguez [:mai] from comment #6)
> > Comment on attachment 8395187 [details] [review]
> > patch v1.0
> > 
> > NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> > better understand the B2G approval process and landings.
> > Change into configuration parameters to deactivate the automatic balance
> > actualization
> > [Approval Request Comment]
> > [Bug caused by] (feature/regressing bug #): Feature
> > [User impact] if declined: the possibility of extra charges on the user
> > billing account.
> > [Testing completed]: Yes
> > [Risk to taking this patch] (and alternatives if risky): No risk
> > [String changes made]:No
> 
> :Its too late to add a feature at this stage, is this a regression or a
> fallout from cost control stages ?
> If not, its unclear why exactly this is needed now. Is see the user impact
> is bad but has this always been the case ?
> 
> Also don't see any automated testscases on the patch, do we have existing
> test coverage in this area of code. I checked with mozilla QA and they said
> tef would be in the best position to verify this on on master and ensure no
> fallouts are seen. Can you confirm this is on your radar for verification ?
> may be Massimo and Lolican help here.


I will help and test that change the automatic check for the balance to only manual.
Comment on attachment 8395187 [details] [review]
patch v1.0

Thanks for the response, approving and lest get Loli's verification in parallel.
Attachment #8395187 - Flags: approval-gaia-v1.3?(release-mgmt) → approval-gaia-v1.3+
Keywords: verifyme
QA Contact: lolimartinezcr
(In reply to Loli from comment #9)
> (In reply to bhavana bajaj [:bajaj] from comment #7)
> > (In reply to marina rodríguez [:mai] from comment #6)
> > > Comment on attachment 8395187 [details] [review]
> > > patch v1.0
> > > 
> > > NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> > > better understand the B2G approval process and landings.
> > > Change into configuration parameters to deactivate the automatic balance
> > > actualization
> > > [Approval Request Comment]
> > > [Bug caused by] (feature/regressing bug #): Feature
> > > [User impact] if declined: the possibility of extra charges on the user
> > > billing account.
> > > [Testing completed]: Yes
> > > [Risk to taking this patch] (and alternatives if risky): No risk
> > > [String changes made]:No
> > 
> > :Its too late to add a feature at this stage, is this a regression or a
> > fallout from cost control stages ?
> > If not, its unclear why exactly this is needed now. Is see the user impact
> > is bad but has this always been the case ?
> > 
> > Also don't see any automated testscases on the patch, do we have existing
> > test coverage in this area of code. I checked with mozilla QA and they said
> > tef would be in the best position to verify this on on master and ensure no
> > fallouts are seen. Can you confirm this is on your radar for verification ?
> > may be Massimo and Lolican help here.
> 
> 
> I will help and test that change the automatic check for the balance to only
> manual.

Tested with Peru SIM card
Platform version: 28.0
Build ID: 20140326094428
GIT commit: 0cddd1cc

I have review "config.js" file and I have seen this property: is_free= false, for this reason this is working
Status: RESOLVED → VERIFIED
Keywords: verifyme
Please ignore comment 11, wrong comment, setting verifyme flag again to be tested on master. Thanks!
Status: VERIFIED → RESOLVED
Closed: 7 years ago7 years ago
Keywords: verifyme
(In reply to Beatriz Rodríguez [:brg] from comment #0)

Change the flag: is_free and is_roaming_free from true to false.
- For Colombia, line 5 and line 6 at: https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/costcontrol/js/config/movistar_colombia/config.js
- For Peru(only is_free), line 5 at: https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/costcontrol/js/config/movistar_peru/config.js
- For Uruguay, line 6 and 7 a

(In reply to Noemí Freire (:noemi) from comment #12)
> Please ignore comment 11, wrong comment, setting verifyme flag again to be
> tested on master. Thanks!

Verified as fixed v1.5. The above "config.js"s have had their 'is_free' and 'is_roaming_free' set to false in the latest v1.5 Master Buri build.

-

1) Changing bug status to verified as this was tested against master v1.5, comment #12

2) Removing verifyme, request was only for master.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Tested master and verified
Gecko f1b5b05
Gaia f9a44b5
You need to log in before you can comment on or make changes to this bug.