question mark that appears when password sync is disabled due to master password should be an image

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Gavin, Assigned: markh)

Tracking

Trunk
Firefox 31
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29+ verified, firefox30+ verified, firefox31 verified)

Details

Attachments

(1 attachment)

Bug 970167 added an explanatory link, but it would be nicer for this to be an image of a questionmark. I think we have one of those around somewhere...
Assignee: nobody → mhammond
Mark, if you want this change to be in 29, please provide a patch this week. Thanks :)
It seems chrome://global/skin/icons/question-16.png is a reasonable image to use.  I've only tested this on Windows.
Attachment #8403820 - Flags: review?(ttaubert)
Comment on attachment 8403820 [details] [diff] [review]
0001-Bug-986636-use-icon-instead-of-on-sync-prefs-when-ma.patch

Review of attachment 8403820 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, that looks much better!

::: browser/themes/osx/preferences/preferences.css
@@ +235,5 @@
>  }
>  
> +#fxa-pweng-help-link > image {
> +  list-style-image: url("chrome://global/skin/icons/question-16.png");
> +}

Make that:

#fxa-pweng-help-link > image {
  width: 16px;
  height: 16px;
  list-style-image: url("chrome://global/skin/icons/question-16.png");
}

@media (min-resolution: 2dppx) {
  #fxa-pweng-help-link > image {
    list-style-image: url("chrome://global/skin/icons/question-32.png");
  }
}

And everything looks fine on Retina, too :)
Attachment #8403820 - Flags: review?(ttaubert) → review+
Comment on attachment 8403820 [details] [diff] [review]
0001-Bug-986636-use-icon-instead-of-on-sync-prefs-when-ma.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync
User impact if declined: Sync prefs pane is ugly!
Testing completed (on m-c, etc.): Landed on fx-team and green there.
Risk to taking this patch (and alternatives if risky): Low risk, limited to
sync
String or IDL/UUID changes made by this patch: None
Attachment #8403820 - Flags: approval-mozilla-beta?
Attachment #8403820 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/6a39967bd426
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Attachment #8403820 - Flags: approval-mozilla-beta?
Attachment #8403820 - Flags: approval-mozilla-beta+
Attachment #8403820 - Flags: approval-mozilla-aurora?
Attachment #8403820 - Flags: approval-mozilla-aurora+
Keywords: verifyme
I've verified the fix on Win 7 x64, Mac OS X 10.9.2, Ubuntu 13.04 x64, using Firefox 29 Beta 8 (BuildID: 20140414143035), latest 30.0a2 Aurora (BuildID: 20140415004003) and latest 31.0a1 Nightly (BuildID: 	20140415030203). The new question mark image from chrome://global/skin/icons/question-16.png is displayed.
You need to log in before you can comment on or make changes to this bug.