Closed Bug 986895 Opened 8 years ago Closed 4 years ago

echo.msk.ru — HTML5 Video not working in Firefox

Categories

(Web Compatibility :: Mobile, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: caspar137, Unassigned)

References

()

Details

(Whiteboard: [country-ru][video][m3u8][notcontactready])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140224133112

Steps to reproduce:

I try watch videostream at for example http://www.echo.msk.ru/tags/2673/


Actual results:

I see message "No video with supported format and mime type found".

Other browsers (Opera, Chromium) show video well. 
Flash-plugin is installed.
Operation system -- Fedora 20.


Expected results:

I'll see videotranslation.
From browser console:
"HTTP "Content-Type" of "application/vnd.apple.mpegurl" is not supported. Load of media resource http://cdn0.onlinetv.ru:1935/echomsk/_definst_/echomsk.stream/playlist.m3u8?s=pbev1d9c60h1gqeob5vtcppq87 failed.
Component: Untriaged → Mobile
Product: Firefox → Tech Evangelism
Version: 27 Branch → unspecified
Depends on: m3u8video
I found the cause of my problem -- add-on FlashBlock.
Summary: Some videostreams not playing in firefox, but playing well in other browsers → echo.msk.ru — HTML5 Video not working in Firefox
(In reply to Eugene from comment #2)
> I found the cause of my problem -- add-on FlashBlock.
Nice to hear it, but I still would like to keep this bug open. "Echo of Moscow" is one of leading news site in Russia, (see http://en.wikipedia.org/wiki/Echo_of_Moscow and http://www.alexa.com/siteinfo/echo.msk.ru ) and it's inconvenient that its video streams don't work without Flash fallback.
Thanks for the bug report. When you tested with Opera and Chromium, was Flash enabled in those browsers?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-ru][video][m3u8][notcontactready]
Yes. Flash-plugin was enabled in Opera and in Chromium
I expect this site to fail in pretty much the same way in those browsers if Flash is disabled, can you test for me? TIA.
Yes. It fails. It says: "Install flash"
This is working for me now, without flash.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.