sherlock-holmes.de - mozilla getting Netscape 4 version of site with layers

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: diego, Unassigned)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [LAYER][PROPRIETARY-DOM] [country-de] [javascript], URL)

(Reporter)

Description

17 years ago
This is an online detective game. Go to the URL. You will see an image of a
house. There should be some links hidden in the image, however mozilla displays
the link layer below the image so that the mouse cursor turns into a link cursor
over the background below the image.

If I set my useragent to IE via
user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 5.5;
Windows 98; Win 9x 4.90)");the site works without problems and show source
brings up completely different HTML.

I am no expert on the matter. Am I right in my assessment that we are served the
nonstandard NN4 version of the site and fail to display it correctly? If
somebody with a little more expertise can confirm my diagnose I will gladly
contact the webmasters in german and try to resolve the issue.

The site works without problems in IE, Opera and NN4, mozilla 0.9.3 latest
nightly builds and Netscape 6.1 do not display the site correctly.
(Reporter)

Comment 1

17 years ago
Correction: Opera 5.12 works when masquerading as IE.
Keywords: 4xp
<offtopic>So that's why Mozilla's stats aren't up! Our users are telling servers
that it's IE. Not that it should matter, but i've never been an advocate of
changing your user-agent string. I've never seen people change cars to say
"Ford" instead of "Chevy." I've not seen anyone scratch off "Dell" from their
computer and stick a "Gateway" sticker on to it.</offtopic>

Anyway, the site will use either document.layers or document.all; both of which
are unsupported by Mozilla.  Confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: 4xp
Summary: mozilla getting Netscape 4 version of site with layers → sherlock-holmes.de - mozilla getting Netscape 4 version of site with layers
Whiteboard: [LAYER][PROPRIETARY-DOM]
(Reporter)

Comment 3

17 years ago
I can see no document.all in the IE version of the site.

Under Linux you have to use a different useragent string:

user_pref("general.useragent.override", "Mozilla/5.0 (compatible; MSIE 5.5;
Windows 98; Win 9x 4.90)");

because mozilla refuses to start with the following error

INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

Comment 4

17 years ago
Diego: the page uses frames.  In different frames are different things but you
can see the following in various frames.  And FWIW, if you are seeing different
content that Mozilla can't render because of your useragent, that is not a bug.
 That's your fault for overriding the UA.


 if (document.layers)
	{
		//Netscape:
		document.layers['t'+num].visibility = vis?"show":"hide";
	}
	else
	{
		//Microsoft:
		document.all['t'+num].style.visibility = vis?"visible":"hidden";
	}

............................

<ilayer width=200 height=175> <layer left=0 top=0>
<img src='../../crime/case01/roo/roo11.jpg' width=200 height=175>
</layer>
<layer left=0 top=174>
<img src='../../crime/case01/roo/roo04a.gif' width=1 height=1>
</layer>
<layer left=0 top=174>
<img src='../../crime/case01/roo/roo04b.gif' width=1 height=1>
</layer>
<layer left=0 top=174>
<img src='../../crime/case01/roo/roo07a.gif' width=1 height=1>
</layer>
<layer top=0 left=0'>
<img border=0 src='../../crime/pics/frame200x175.gif' width=200 height=175
USEMAP='#picmap'>
</layer></ilayer>

(Reporter)

Comment 5

17 years ago
In case this is unclear, mozilla renders the page fine with the useragent set to
IE. Why should that not be a bug? Remember that we are in the Tech Evangelism
section. I assume that if the IE version works better, mozilla should get that
version of the site instead, am I wrong? And why does mozilla render one version
and not the other if both are equally far away from the standards?


<offtopic> Christopher, I should clarify the issue. I dislike changing useragent
strings as much as you do. The concept of the useragent was flawed from the
beginning. Standards are the solution, not browser sniffing. Nevertheless
useragents are an excellent debugging aid and I employ them as such. Bug 46029
will be a boon to bug triaging once it gets fixed. BTW, I scratched off the
"Designed for Microsoft Windows 98" sticker from my notebook and replaced it
with one reading "GNU/Linux inside" ;) </offtopic>

Comment 6

17 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Component: European → West Europe
QA Contact: momoi → caillon

Comment 7

17 years ago
Diego, I don't understand the problem you describe. With N62 and IE5, I do get
different behaviour, but don't see the house image links problem. 

Can you elaborate ?

Accepting bug. Setting P4
Status: NEW → ASSIGNED
Priority: -- → P4
(Reporter)

Comment 8

17 years ago
Of course I can elaborate, Tristan.

On the page you have an image of an old manor, like this:
 _______
|       |
| image |
|       |
 -------

Below that image is a square containing links, like so:
 _______
|       |
| links |
|       |
 -------

But the links are supposed to be inside the image like this:
 _______
| image |
|       |
| links |
 -------

It is a detective game and clicking certain parts of the image is part of the
game. Try this in IE or change your useragent to see the difference.

Thanks for accepting the bug. This is a german site. I had planned to get in
touch with them but haven't got around to it yet. I had hoped that someone might
be able to point out a more general solution. I will approach them next week and
ask them to serve the IE version of the site to mozilla browsers. This should be
an acceptable workaround. Since I suppose that communication will be easier in
german, I will then assign that bug to me, if you do not mind.
(Reporter)

Comment 9

17 years ago
I sent a mail to the webmaster describing the problem and asking for a change in
their browser sniffing code so that mozilla gets served the IE version of the
site. I am therefore assigning this bug to myself and will keep you up to date
in this bug if and when I get an answer. I can post the mail here if somebody is
interested, but it is in german. If interest is really strong I can translate it.

I just had a look at the site's browser sniffing code, they try to shut out
Netscape 6.x Browsers like so (text abbreviated - it says "You are using
Netscape 6.x, unfortunately it is incompatible with our site, try IE):

   else if ((!document.layers) && (!document.all) && (document.getElementById))
   {
      alert("HINWEIS: Die verwendest einen Netscape 6.x Browser...");
   }

The funny thing is that it does not work. I just tried the site with 6.2 under
Linux, that piece of code does not get triggered because the Netscape 4
detection gets triggered first...
Assignee: nitot → diego
Status: ASSIGNED → NEW
Priority: P4 → P2
(Reporter)

Comment 10

17 years ago
The webmaster answered, he was very friendly but overworked and regretted not
having time to fix this at the moment. There are some more problems with the
site that switching useragents does not circumvent. At

http://www.sherlock-holmes.de/crime/d/book11.htm

you are supposed to see a glove at the top, a key in the lower right corner and
a detective in the lower left corner. None of these are visible, though.

What's the procedure now? Shall I mark this WONTFIX or just leave it assigned?
Status: NEW → ASSIGNED

Comment 11

17 years ago
Diego, leave it assigned.  I am marking a milestone of one month from now, but
if you don't feel that it is reasonable to expect this fixed by Dec, please mark
future instead.  We've found that webmasters often need 'help' - if you supply
them code to fix their site, they tend to do it faster.  If you need help with
this, let me know or visit the folks on #evangelism - irc.mozilla.org
Target Milestone: --- → Dec
(Reporter)

Comment 12

17 years ago
I do not expect this to get fixed anytime soon ---> FUTURE

The site works better if moz gets served the IE version, however it is far from
correct then, although I suppose it should be possible to play the game at least.

The NN4 version of the site uses layers all over, the IE version document.all,
neither of which we support. The webmaster told me I was the first Netscape6
user to ever complain to him, so he does not really have a big incentive to fix
the problem. I am afraid only a redesign would eliminate all the problems, but I
am no web programming wizard. Are there some documents available on the subject
of migrating sites towards standards compliant designs? This would be a good
start. Thanks.
Target Milestone: Dec → Future
move...
Assignee: diego → german
Status: ASSIGNED → NEW
Component: Europe: West → German
QA Contact: z-caillon-obsolete2 → german
The site now seems to work fine using Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.7) Gecko/20040712 Firefox/0.9.1
(Reporter)

Comment 15

15 years ago
I don't see any difference, the links are still below the image and not inside
it, where they belong.
still broken

Comment 17

8 years ago
Funny, after 9 years this bugged site is still here.

Now the browser-sniffing code looks like this:

<script language="JavaScript">
  <!--
   function warp() { eval("docu"+"ment.loca"+"tion='crime/d/book'+'12.h'+'tm';"); }
   function start() { /*eval("win"+"dow.set"+"Timeout('wa'+'rp();',30"+"00);");*/ }
 
   if (parseInt(navigator.appVersion)>0 && parseInt(navigator.appVersion)<4)
   {
      alert ("HINWEIS: Um diese Seite zu besuchen benötigst Du einen Netscape oder Microsoft-Browser der Version 4.x oder neuer!");
   }
   else if (!document.all)
   {
      alert ("HINWEIS: Diese Site funktioniert mit deinem Netscape-Browser. Leider ist der Netscape Browser nicht 100% stabil. Ich empfehle daher den Internet Explorer zu verwenden oder das Spiel oft abszuspeichern! (Vorhängeschloss-Ikone)\n\n[Für die Techniker: Ich weiß es gibt Standards, usw... Aber das ist nicht das Problem. Es sind Probleme im der Javascript-Implementation, Abstürze.]");
   }
   else if ((!document.layers) && (!document.all) && (document.getElementById))
   {
      alert("HINWEIS: Die verwendest einen Netscape 6.x Browser. Leider ist dieser nicht kompatibel. Du kannst Todesursache Mord leider nicht mit diesem Browser spielen. Ich empfehle den Internet Explorer (www.microsoft.com) oder Opera (www.opera.com) zu verwenden. Danke für dein Verständnis...\n\n[Für die Techniker: Ich weiß es gibt Standards, usw... Aber das ist nicht das Problem. Es sind Probleme im der Javascript-Implementation, Abstürze.]");
   }
   else start();
This seems to work. The links are all on the images for me. Firefox 30.
Assignee: german → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: German → Desktop
Resolution: --- → WORKSFORME
Whiteboard: [LAYER][PROPRIETARY-DOM] → [LAYER][PROPRIETARY-DOM] [country-de] [javascript]
You need to log in before you can comment on or make changes to this bug.