Status

()

defect
RESOLVED WONTFIX
18 years ago
16 years ago

People

(Reporter: tseng_mike, Assigned: hyatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

18 years ago
Implement element tag to allow inserting anonymous content as a parent of the
element.
No dupes found. Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1

Comment 2

18 years ago
Will this be implemented for 1.0?

--pete
Reporter

Comment 3

18 years ago
Nominating for 1.0, there is no work around to insert nodes as parent. Makes
extending tags like <img/> impossible. Unless someone can enlighten me
Keywords: mozilla1.0
OS: Windows 2000 → All
Bug hasn't been touched in nearly a year; updating milestone and removing 1.0 
keyword as appropriate.

Sounds interesting.  Are you sure there's no workaround?  I recently hit on the 
idea of having the constructor for a binding do the following:

window.addEventListener("load", this.actionDesired(), true);

where you have your desired DOM manipulations take place in a different method 
of the binding.
Keywords: mozilla1.0
Target Milestone: mozilla1.0.1 → mozilla1.0.3
Sorry, that actionDesired function should not have parentheses.

Comment 6

17 years ago
Don't target a bug that doesn't even have code for the stable 1.0.x branch.
Target Milestone: mozilla1.0.3 → ---
Cc'ing bryner in case he can take this bug.

/be
<element> won't allow this; we've removed this feature from the spec. (<element> 
still exists but does something unrelated and something whose absence is easy to 
work around.)

WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Just curious, and because others might be interested, I ask the questions here.
Why has it been removed, and where can I find the new updated spec?
Will it be in xbl 1.1 (or 2.0)?
There is no work around to insert nodes as parent,without the use of some ugly
scripting. See comment 3


You need to log in before you can comment on or make changes to this bug.