Closed Bug 987175 Opened 6 years ago Closed 6 years ago

Hide "Add panel" settings item for fx30

Categories

(Firefox for Android :: General, defect, P1)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- unaffected
firefox30 --- verified
firefox31 --- unaffected
fennec 30+ ---

People

(Reporter: Margaret, Assigned: Margaret)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Right now, this dialog only contains items if users have add-ons installed that register panels, and it's pretty safe to assume that nobody will have these installed for 30, since they don't exist yet.

Instead of showing an unhelpful dialog, I think we should just hide this settings item.

For Fx30, the plan is just to support two RSS add-ons that we build ourselves (one of which wouldn't even register a panel), and we can promote those snippets.

This actually raises a bigger question about the usefulness of this picker. I'm tempted to say that we should rethink how we implemented it, and instead use it to display a list of promoted panel add-ons that we ship in a JSON file. But we can discuss that elsewhere.
Assignee: nobody → margaret.leibovic
Priority: -- → P1
Here's a patch that we can land on aurora to disable this. We can keep the item enabled on nightly, but we'll work on bug 987869 to try to make this more useful.
Attachment #8396715 - Flags: review?(liuche)
Comment on attachment 8396715 [details] [diff] [review]
Hide "Add panel" settings item

Review of attachment 8396715 [details] [diff] [review]:
-----------------------------------------------------------------

Only one thing to check - if we are hiding the panels picker, do we need to do things to the strings as well, so they aren't localized without a UI element? I could see those strings falling through the cracks in 30 because there is no UI element, and then not getting localized in later versions because they're not new strings.

:flod, do you have any input on how to handle this?
Attachment #8396715 - Flags: review?(liuche) → review+
Flags: needinfo?(francesco.lodolo)
(In reply to Chenxia Liu [:liuche] from comment #2)
> Only one thing to check - if we are hiding the panels picker, do we need to
> do things to the strings as well, so they aren't localized without a UI
> element? I could see those strings falling through the cracks in 30 because
> there is no UI element, and then not getting localized in later versions
> because they're not new strings.

The current approach is fine: don't touch strings on Aurora (which includes both adding or removing), just disabling the feature is OK.

All localizers rely on tools to know how many strings are untranslated, so that's not an issue and there's no risk involved.
Flags: needinfo?(francesco.lodolo)
Comment on attachment 8396715 [details] [diff] [review]
Hide "Add panel" settings item

[Approval Request Comment]
Bug caused by (feature/regressing bug #): disabling feature added in 942875 (although this part is only in 30)
User impact if declined: "Add list" item in home settings is confusing
Testing completed (on m-c, etc.): tested locally, only want to land on aurora
Risk to taking this patch (and alternatives if risky): low-risk, disabled a settings item
String or IDL/UUID changes made by this patch: none
Attachment #8396715 - Flags: approval-mozilla-aurora?
tracking-fennec: ? → 30+
Attachment #8396715 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Setting tracking flags to reflect this is only something we want to do on 30.

https://hg.mozilla.org/releases/mozilla-aurora/rev/c4a49783aa22
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Verified as fixed in build 30 beta 1.
Device: Samsung Galaxy R (Android 2.3.4).
Status: RESOLVED → VERIFIED
Depends on: 1010268
Setting P1 hub bugs to block hub v1 EPIC bug (targeting fx30 release).

Filter on epic-hub-bugs.
Blocks: 1014025
You need to log in before you can comment on or make changes to this bug.