Closed Bug 987223 Opened 6 years ago Closed 5 years ago

No visible H.264 video playback on MPEG-4 AVC (part 10) (avc1) (Planar 4:2:0 YUV) on Android 4.0 devices

Categories

(Core :: Audio/Video, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
fennec + ---

People

(Reporter: aaronmt, Assigned: eflores)

References

()

Details

(Keywords: reproducible)

Currently on these known devices below, on playback of this particular video, in stream0 there is no visible playback. stream1 audio works fine.

* Samsung Galaxy Note II (4.1.2)
* Samsung Galaxy Tab 2 (4.2.2)
* Samsung Galaxy Tab (4.0.4)
* Samsung Galaxy S3 (4.3) 
* Samsung Galaxy Note (4.0.4)
* Motorola RAZR XT910 (4.0.4)
* ZTE x86 (4.0.4)

http://images.apple.com/media/us/mac/30-years/2014/feature/mac-30/mac30-feature-us-20140124_640x360h.mp4
On my device at hand the Samsung Galaxy Note II, there is not much logging dumped to logcat [1] during playback. Edwin, do you have a custom build available to dump more logging if need be?

[1]
I/MediaPluginHost(13585): Android Version is: 18
I/MediaPluginHost(13585): Android Release Version is: 4.3
I/MediaPluginHost(13585): Android Device is: GT-N7100
I/MediaPluginHost(13585): Android Manufacturer is: samsung
I/MediaPluginHost(13585): Android Hardware is: smdk4x12
I/MediaPluginHost(13585): Loading OMX Plugin: libomxpluginkk.so
I/MediaPluginHost(13585): OMX plugin successfully loaded
I/OMXClient(13227): Using client-side OMX mux.
I/OMXCodec(13227): Attempting to allocate OMX node 'OMX.SEC.aac.dec'
I/OMXCodec(13227): Successfully allocated OMX node 'OMX.SEC.aac.dec'
I/OMXCodec(13227): OMXCodec::configureCodec 2 + 44100 ++ 
I/OMXCodec(13227): OMXCodec::configureCodec OutCh  2 + 2, Err : 0 ++ 
I/OMXCodec(13227): [OMX.SEC.aac.dec] allocating 5 buffers of size 1572864 on input port
I/OMXCodec(13227): [OMX.SEC.aac.dec] allocating 9 buffers of size 24576 on output port
I/SEC_BASE_COMP( 1948): SEC_OMX_ComponentStateSet: Cur(1) -> Dest(2)
I/SEC_BASE_COMP( 1948): SEC_OMX_ComponentStateSet: Cur(2) -> Dest(3)
Flags: needinfo?(edwin)
Assignee: nobody → edwin
tracking-fennec: ? → +
It looks like the demuxer on (some?) Samsung devices just don't recognise the track as H264; might be a badly muxed file. Are there other videos this has been observed on? If not I think this is a WONTFIX.
Flags: needinfo?(edwin)
Also reproducible on the following devices:
* Samsung Galaxy Nexus (4.2.1)
* Alcatel One Touch 8008D (4.1.2)
* Motorola RAZR XT910 (4.0.3)
Renominating because of our growing concern for the state of video issues in fennec
tracking-fennec: + → ?
Aaron - Does this play in Chrome?

Edwin - What data do we need to determine if this is something we need to fix? Should we be sending back some telemetry?
Flags: needinfo?(aaron.train)
(In reply to Mark Finkle (:mfinkle) from comment #5)
> Aaron - Does this play in Chrome?

Yes
Flags: needinfo?(aaron.train)
Anthony, who do you want to assign this to?
tracking-fennec: ? → 33+
Flags: needinfo?(ajones)
I can play it on desktop with the internal MP4 demuxer so when 1014614 is operational it should work properly.
Flags: needinfo?(ajones)
tracking-fennec: 33+ → 35+
Hopeful that this is all resolved with MediaCodec implementation, maybe? I'll take a look with these devices if I can muster them up.
QA Contact: aaron.train
The 4.1+ devices are all playing now. The 4.0 devices still have problems. Fixed via bug 1014614. How do you want to handle bug closure?
(In reply to Aaron Train [:aaronmt] from comment #10)
> The 4.1+ devices are all playing now. The 4.0 devices still have problems.
> Fixed via bug 1014614. How do you want to handle bug closure?

Can you just dup this, and change the summaries to reflect android version and the affected devices, then close the 4.1+ ones?
Let's just re-summarize this.
Summary: No visible H.264 video playback on MPEG-4 AVC (part 10) (avc1) (Planar 4:2:0 YUV) → No visible H.264 video playback on MPEG-4 AVC (part 10) (avc1) (Planar 4:2:0 YUV) on Android 4.0 devices
Status: NEW → RESOLVED
tracking-fennec: 35+ → +
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.