Clicking "remove cc" checkbox, but not selecting user produces "Software Error"

RESOLVED FIXED in Bugzilla 2.16

Status

()

--
minor
RESOLVED FIXED
17 years ago
6 years ago

People

(Reporter: mozilla.org, Assigned: jacob)

Tracking

2.14
Bugzilla 2.16

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
If a user, while modifying a bug selects the remove CC checkbox, but doesn't
actually select any of the users, it blows up on process_bug.cgi, line 675:

672          $cc_add = $::FORM{newcc};
673          # We came from bug_form which uses a select box to determine what cc's
674          # need to be removed...
675          if (defined $::FORM{removecc}) {
676              $cc_remove = join (",", @{$::MFORM{cc}});
677          }
678      }


The error message is "Can't use an undefined value as an ARRAY reference at
/home/bugzilla/process_bug.cgi line 675"
(Assignee)

Comment 1

17 years ago
Created attachment 48694 [details] [diff] [review]
patch - ignore the cc selectbox if nothing is selected
(Assignee)

Comment 2

17 years ago
Simple, one line fix.  If there aren't any selections and the remove cc box is
checked, pretend like the remove cc box isn't checked.
Assignee: myk → jake
Keywords: patch, review
Target Milestone: --- → Bugzilla 2.16
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Comment on attachment 48694 [details] [diff] [review]
patch - ignore the cc selectbox if nothing is selected

looks good, works.  r=myk, no second review needed. checked in.
Attachment #48694 - Flags: review+
Checked in.  Resolving fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

17 years ago
*** Bug 104391 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.