Closed Bug 987454 Opened 6 years ago Closed 6 years ago

[Messages] The sent message is not painted after sending

Categories

(Core :: Panning and Zooming, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: dietrich, Unassigned)

References

Details

Attachments

(1 file)

hrm, i touched the screen and it painted the rest of the way so couldn't get the screenshot.

i hit send, the message sent.

but the visible message bubble was just a white line. then when i touched it, the whole sent message was visible.
Dietrich, which Gecko/Gaia version do you use?
Oh sorry, bad bug filer!

Using master (1.5) build from 3/24.
I think I encountered this too on my Peak. I sent an MMS message, got a reply, then replied again and when my reply was sent the bubble wasn't shown. This was with Geeksphone master build from the 21st of March.
Yeah, I see this too. This looks like a painting or APZC issue.

As soon as the message is 2 lines, I see the issue.

So here is a STR:
* open the Messages app
* open an existing thread
* send a message with 2 lines

Kats, can you have a look?
Flags: needinfo?(bugmail.mozilla)
QAWanted: does that happen on 1.4?
Keywords: qawanted
Summary: sent message not visible → [Messages] The sent message is not painted after sending
Component: Gaia::SMS → Panning and Zooming
Product: Firefox OS → Core
Is there a way to reproduce these STR without a SIM card? I can make local changes to my codebase if needed.
Flags: needinfo?(bugmail.mozilla) → needinfo?(felash)
Jason, I'm waiting for a qawanted for 5 days here, maybe because it's not in the Firefox OS Product? Could you help? Thanks!

Kats, I'll have a look.
Flags: needinfo?(jsmith)
Actually, I don't reproduce it anymore on a current 1.5. Dietrich, do you still see this on a newer build?

Now I'd like to know whether it happens on 1.4 though...
Flags: needinfo?(felash) → needinfo?(dietrich)
I reproduced this only once ever.
Flags: needinfo?(dietrich)
(In reply to Julien Wajsberg [:julienw] (away until March 24) from comment #8)
> Jason, I'm waiting for a qawanted for 5 days here, maybe because it's not in
> the Firefox OS Product? Could you help? Thanks!
> 
> Kats, I'll have a look.

Note for the future - in order to get onto the qawanted queries, you either need to have:

* A blocking flag set
* In the Firefox OS product

So in this bug's case, I'd flag the blocking flag as backlog if it's worth fixing, as that will cause this bug to show up in our bug queries.
blocking-b2g: --- → backlog
Flags: needinfo?(jsmith)
QA: please test the STR in comment 4 in 1.4. Thanks !
Please let me know if you still see this with bug 1010119 applied.
Jason, looks like this bug is still not showing up in your queries :)

I'll close it now because I clearly don't reproduce it now, but I still want to know how qawanted works for this type of bugs.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jsmith)
Resolution: --- → WORKSFORME
It actually is in our queries, it's just not on the top of our priority queue.
Flags: needinfo?(jsmith)
Keywords: qawanted
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.