Closed Bug 987457 Opened 6 years ago Closed 6 years ago

rename ProtoAndIfaceArray

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: froydnj, Assigned: froydnj)

References

Details

Attachments

(1 file)

The name shouldn't reflect an implementation, especially an implementation that's not entirely accurate after bug 948445 lands.
Fortunately, Array and Cache have the same number of letters, so no
indentation hazards.  This patch applies on top of bug 948445.
Attachment #8396089 - Flags: review?(bzbarsky)
Comment on attachment 8396089 [details] [diff] [review]
rename ProtoAndIfaceArray to ProtoAndIfaceCache

>+    ProtoAndIfaceCache& protoAndIfaceArray = *GetProtoAndIfaceArray(global);

Rename the variable and the method too?

>+  ProtoAndIfaceCache* protoAndIfaceArray = new ProtoAndIfaceCache(aKind);

And the variable here.

>+  ProtoAndIfaceCache* protoAndIfaceArray = GetProtoAndIfaceCache(obj);

And likewise.

>+  ProtoAndIfaceCache& protoAndIfaceArray = *GetProtoAndIfaceCache(aGlobal);

And here.

>+  ProtoAndIfaceCache& protoAndIfaceArray = *GetProtoAndIfaceCache(aGlobal);

And another in the codegen.

r=me with those fixed up.
Attachment #8396089 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/mozilla-central/rev/892a3da3d9b4
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.