Closed Bug 987609 Opened 7 years ago Closed 7 years ago

[Camera][Madai][UX] Gallery/preview Image number should be visible when swiping

Categories

(Firefox OS Graveyard :: Gaia::Camera, enhancement)

PowerPC
Gonk (Firefox OS)
enhancement
Not set
normal

Tracking

(b2g-v1.4 verified, b2g-v2.0 verified)

VERIFIED FIXED
1.4 S5 (11apr)
Tracking Status
b2g-v1.4 --- verified
b2g-v2.0 --- verified

People

(Reporter: dmarcos, Assigned: justindarc)

References

Details

(Keywords: late-l10n, Whiteboard: [m?])

Attachments

(2 files)

The number is hidden when swiping (see attached video). 1/5, 2/5, 3/5... are not displayed.
Attached video hiddenNumber.MOV
Blocks: 983405
Severity: normal → enhancement
Summary: [Camera][Madai] Gallery/preview Image number should be visible when swiping → [Camera][Madai][UX] Gallery/preview Image number should be visible when swiping
Whiteboard: [m?]
Amy want to hide all preview menu(camera back, count number, control bar).
Need to check from Amy.
Flags: needinfo?(amlee)
Hi Hyuna, 

Just wanted to clarify the behavior of the fade in/fade out of the preview menu (this includes camera back, count number, control bar). Menu disappears only when left idle or when the user taps the screen to turn off the menu. If the menu is on and the user is swiping through the images, the menu should stay visible until either the user taps to hide the menu or if the camera is left idle. 

Right now the menu fades out even when the user is swiping through the gallery so this behavior is incorrect. If the menu is on and the user is swiping through the images, the menu should stay on. 

Let me know if you have any questions
Flags: needinfo?(amlee)
Assignee: nobody → jdarcangelo
Keywords: late-l10n
Hi everyone...

UX discussed this behaviour earlier this week and will be making a change to the spec to align it with gallery. In gallery controls do not automatically fade out and instead are hidden on tap and shown on tap. We would like to adopt the same behaviour in camera preview and will be updating the spec to reflect this change. Let me know if you have any questions.

- Rob
Hey Axel, do we need to localize numbers for the photo/video count? (e.g 1/2)
Flags: needinfo?(axel)
As discussed in yesterday's triage, the fix for this issue will be to *NOT* fade out the on-screen controls after a timeout since tapping already shows/hides the controls.
Attached file pull-request (master)
David: This patch simply removes the fade in/out timeout as discussed in yesterday's triage.
Attachment #8400946 - Flags: review?(dflanagan)
I'm not sure if Axel monitors that needinfo address, so also setting needinfo for :pike
Flags: needinfo?(l10n)
Comment on attachment 8400946 [details] [review]
pull-request (master)

This works except that when I play a video and pause it then resume it, then when I get to the end of the video, the controls do not reappear like they are supposed to.

But that can be handled in a followup bug. I think it is worth landing this as is.  Will you file the followup?
Attachment #8400946 - Flags: review?(dflanagan) → review+
Followup: Bug 991430 - [Camera] Playing/Pausing/Playing a video from preview causes controls to disappear
Landed on master:

https://github.com/mozilla-b2g/gaia/commit/1a95c5414ab09db0e2063bcbdb5fbe5e528bff46
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to Tiffanie Shakespeare from comment #5)
> Hey Axel, do we need to localize numbers for the photo/video count? (e.g 1/2)

I think the best way to go is a localizable string with placeholders, e.g.

> currentItem = {{current}}/{{total}}

And a localization comment explaining what these parameters are at run-time.
Flags: needinfo?(axel)
Flags: needinfo?(l10n)
Bulk edit for camera bugs.

If earlier comments do not show how this bug landed to master, it probably landed as part of https://github.com/mozilla-b2g/gaia/pull/17599 which merged the camera-new-features branch into master.

This bug was uplifted from master to v1.4 as part of https://github.com/mozilla-b2g/gaia/commit/a8190d08e61316a86bba572ba8d894d081a20530
Target Milestone: --- → 1.4 S5 (11apr)
The issue is no longer reproduces on the latest 1.4 and master builds
The image counter is visible all the time when swiping the gallery


1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140408000202
Gaia: 26983f356ecb1bcf30e862d334b5de790071803e
Gecko: 70b076fc7558
Version: 30.0a2
Firmware Version: v1.2-device.cfg

1.5 Environmental Variables:
Device: Buri Master 
BuildID: 20140408040204
Gaia: 1958454595b1fa0e061f0652ae965629993f5708
Gecko: 8883360b1edb
Version: 31.0a1
Firmware Version: v1.2-device.cfg
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.