Closed Bug 987615 Opened 7 years ago Closed 7 years ago

Australis menu is broken in customization mode with long strings and unsupported hyphenation

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: flod, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 files, 1 obsolete file)

Attached image Polish screenshot
While doing some tests on Aurora, I noticed the Polish Australis menu is pretty broken on OS X.

Problem is that we support hyphenation only for a limited set of locales
https://developer.mozilla.org/en-US/docs/Web/CSS/hyphens#Notes_on_supported_languages

And Polish is not among them, so the Full Screen button breaks the layout.

The only solution seems to be abbreviating the string or adding manual hyphenations into the string.
One personal note: especially after bug 979477 landed, I'm a big fan of "let's get rid of the strings entirely".
(In reply to Francesco Lodolo [:flod] from comment #0)
> Problem is that we support hyphenation only for a limited set of locales
> https://developer.mozilla.org/en-US/docs/Web/CSS/
> hyphens#Notes_on_supported_languages
> 
> And Polish is not among them, so the Full Screen button breaks the layout.

Is there a bug on file to add Czech, Polish and Brazilian Portuguese hyphenation rules to the pack? The tables used by Tex and OpenOffice are public domain (I only checked Polish and made assumptions about the other two), so how much work would it be to port them?
Flags: needinfo?(hsivonen)
Flags: needinfo?(francesco.lodolo)
See also bug 966818 which might have clues.
I don't have that kind of information, only bug I'm aware is bug 672320

Note, talking from experience: public domain is not enough, license matters (that's the reason why we can't ship our own localized build with a dictionary).
Flags: needinfo?(francesco.lodolo)
We can at least make sure these long labels don't fudge up the layout.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Component: Toolbars and Customization → Theme
Flags: needinfo?(hsivonen)
OS: Mac OS X → All
Hardware: x86 → All
Summary: Australis menu is broken with long strings and unsupported hyphenation → Australis menu is broken in customization mode with long strings and unsupported hyphenation
This WFM on win8.
Attachment #8396469 - Flags: review?(jaws)
Comment on attachment 8396469 [details] [diff] [review]
fix layout of buttons which are too long in customize mode,

Review of attachment 8396469 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
@@ +244,5 @@
>  .panel-customization-placeholder-child {
>    -moz-appearance: none;
>    -moz-box-orient: vertical;
>    width: calc(@menuPanelButtonWidth@);
> +  min-width: 1px;

please include a comment about this hack. in fact, since it's a hack, see if min-width:0.01px will work.

can we make it so that the min-width rule is only applied to the toolbarpaletteitem?

btw, i think this hack is needed because the toolbarpaletteitem is the child of #PanelUI-contents instead of the actual toolbarbutton.
Attachment #8396469 - Flags: review?(jaws) → review+
Attachment #8396469 - Attachment is obsolete: true
Comment on attachment 8396495 [details] [diff] [review]
fix layout of buttons which are too long in customize mode,

Review of attachment 8396495 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
@@ +248,5 @@
>    height: calc(51px + 2.2em);
>  }
>  
> +toolbarpaletteitem[place="panel"]:not([haswideitem=true]) > .toolbarbutton-1 {
> +  min-width: 0.01px;

please add a comment here explaining why this hack is necessary, and if possible try to use min-width:0 here, since i think that may work as well.
Attachment #8396495 - Flags: review?(jaws) → review+
https://hg.mozilla.org/integration/fx-team/rev/946354936830


This will fix the layout, but the current strings will be cut off until someone either makes them smaller or adds some shy hyphens to them.

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #9)
> Comment on attachment 8396495 [details] [diff] [review]
> fix layout of buttons which are too long in customize mode,
> 
> Review of attachment 8396495 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/themes/shared/customizableui/panelUIOverlay.inc.css
> @@ +248,5 @@
> >    height: calc(51px + 2.2em);
> >  }
> >  
> > +toolbarpaletteitem[place="panel"]:not([haswideitem=true]) > .toolbarbutton-1 {
> > +  min-width: 0.01px;
> 
> please add a comment here explaining why this hack is necessary, and if
> possible try to use min-width:0 here, since i think that may work as well.

Comment added, but min-width: 0 does not work.
Whiteboard: [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/946354936830
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 31
Comment on attachment 8396495 [details] [diff] [review]
fix layout of buttons which are too long in customize mode,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: strings in some locales cause the panel menu layout to go haywire in customization mode
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, almost only CSS changes
String or IDL/UUID changes made by this patch: none
Attachment #8396495 - Flags: approval-mozilla-beta?
Attachment #8396495 - Flags: approval-mozilla-aurora?
Will 1px work? That seems less hacky than using 0.01px...
(In reply to Alfred Kayser from comment #13)
> Will 1px work? That seems less hacky than using 0.01px...

This was on purpose, please see comment #7. Let's not bikeshed about exactly what the min-width should be, it's not like it'll make much difference.
Attachment #8396495 - Flags: approval-mozilla-beta?
Attachment #8396495 - Flags: approval-mozilla-beta+
Attachment #8396495 - Flags: approval-mozilla-aurora?
Attachment #8396495 - Flags: approval-mozilla-aurora+
Verified as fixed on Windows 7 64 bit, Ubuntu 12.04 and Mac SO X 10.9 using the polish builds of:
- Firefox 29 beta 3 (build ID:20140327113732)
- latest Aurora (build ID:20140328004001)
- latest Nightly (build ID: 20140328030203).
You need to log in before you can comment on or make changes to this bug.