Closed Bug 988011 Opened 6 years ago Closed 6 years ago

HTTP cache v2: minimize number of posts in the payload read code path

Categories

(Core :: Networking: Cache, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 999383

People

(Reporter: mayhemer, Unassigned)

References

(Blocks 1 open bug)

Details

In the past I discovered we do a lot of reposts while reading chunks of payload from the cache.  It has major bad influence on reading performance.  I was hoping we would need to fix this as one of optimizations after the new cache is turned on, but seems like this is too much of a regression.

Attached is a detailed log snippet from a cache2 enabled talos run.

I'd like to try to at least slightly increase performance here with good gain/risk ratio.
Talos results shows enlarging the chunk is enough for now.

Also, I now recall I was playing with removing/minimizing the number of posts before we have the prioritization in the IO thread and I also found low influence of it to my page load tests when the IO prioritization was in the tree.

Lowering impact rate here.
Blocks: cache2afterenable
No longer blocks: cache2enable
Severity: major → normal
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 999383
You need to log in before you can comment on or make changes to this bug.