All users were logged out of Bugzilla on October 13th, 2018

<Enter> on Save Page dialogue cannot `cancel' nor `quit without saving'

VERIFIED DUPLICATE of bug 63728

Status

()

--
minor
VERIFIED DUPLICATE of bug 63728
17 years ago
17 years ago

People

(Reporter: TucsonTester1, Assigned: Brade)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.3+)
Gecko/20010903 Netscape6/6.1b1
BuildID:    20010903

When navigating from the keyboard, the three buttons on the Save Page dialogue,
[Save], [Don't Save], and [Cancel], all result in causing the Save Page As
dialogue to appear.  Transferring keyboard focus between the dialogue`s buttons
using the <Tab> key and depressing <Enter> to engage the different implicit
actions do not change the outcome.  All have the same result of invoking the
Save Page As dialogue/process, no matter which one is <Tab>-selected.


Reproducible: Always

Steps to Reproduce:

        Part I.
        (1) Open a fresh Composer window and enter a little 
                text
        (2) Attempt to close the window _via_ any usual means
                (_e.g.,_ pressing <Alt>+<F4>, clicking top-
                right [X], _etc._)
        (3) Leave the mouse alone
        (4) When the Save Page dialogue appears use the <Tab> 
                key to shift the focus from [Save] to [Don't 
                Save]
        (5) Press <Enter>

        Part II.
        (1) Open a fresh Composer window and enter a little 
                text
        (2) Attempt to close the window _via_ any usual means
                (_e.g.,_ pressing <Alt>+<F4>, clicking top-
                right [X], _etc._)
        (3) Leave the mouse alone
        (4) When the Save Page dialogue appears use the <Tab> 
                key Twice to shift the focus from [Save] to 
                [Cancel]
        (5) Press <Enter>


Actual Results:  Save Page As dialogue appears in either instance.

Expected Results:  In the first instance the aborted document should simply
close without further argument after <Enter> is hit, while [Don't Save] lies
under focus.  And in the case where <Enter> is pressed while [Cancel] holds the
focus, one should simply be returned to editing the document.

Additional Information:
Though it is not visibly apparent, three presses of <Tab> key should shift focus
from the [Save] button to the top-right [X] on the Save Page dialogue.  Pressing
<Enter> at this point has exactly the same effect as the two examples reported
above.  One would expect the outcome to equal clicking <Cancel>.

Workaround: Use the mouse to click a particular button for desired action.

Comment 1

17 years ago
Another workaround is to use the space key instead of the enter key.

*** This bug has been marked as a duplicate of 63728 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified Dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.