<font><p>...</font> adds vertical space

RESOLVED DUPLICATE of bug 33784

Status

()

RESOLVED DUPLICATE of bug 33784
17 years ago
17 years ago

People

(Reporter: kbriscoe, Assigned: attinasi)

Tracking

({testcase})

Trunk
x86
Other
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Trivial, but I'm reporting it anyway. This code:
<table width="100%" bgcolor=beige cellpadding=2>
<tr>
<td>
<font size="1"><p>Test</p></font>
</td>
</tr>
</table>

Produces a different-looking display than this:
<table width="100%" bgcolor=beige cellpadding=2>
<tr>
<td>
<p><font size="1">Test</font></p>
</td>
</tr>
</table>
(i.e. with the P and FONT tags nested differently)
I think the layout should be identical.  I found an example of this on our
school's website, so I figured I may as well report it.
Over to layout..
Assignee: jst → attinasi
Component: DOM HTML → Layout
QA Contact: stummala → petersen
Created attachment 48671 [details]
Two examples above, with red borders around <p>
It looks like the <font> enclosing the paragraph is acting like a block-level
element, or something, as it seems to add extra line space.  This may be a
quirks mode thing to keep other pages from breaking, in which case I suppose it
would be wontfix...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Summary: Minor layout glitch in sloppy old HTML → <font><p>...</font> adds vertical space

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 33784 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.