Closed Bug 988116 Opened 6 years ago Closed 2 years ago

Bluetooth file transfer leaves too many notifications

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect)

x86
macOS
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: dietrich, Unassigned)

References

Details

Master (1.5), Nexus 4, built 3/25.

Currently we emit notifications for a when transfer begins and when complete, so two notifications per transfer.

If you do a few transfers, you quickly end up with a bunch of notifications in the tray.

Instead, we should replace the initial notification with any subsequent notifications, so that there is only one entry per file transfer ever in the tray.
Hey UX, thumbs up or down on this?
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Rob as this is notifications, flagging Jacqueline on supporting since Rob is on PTO.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(jsavory)
Flags: needinfo?(firefoxos-ux-bugzilla)
Our notification API supports replacing existing notifications (bug 892530).
cc Taipei UX Omega and gaia developer Ian working on bluetooth file transfer.
Component: Bluetooth → Gaia::Bluetooth File Transfer
(In reply to Dietrich Ayala (:dietrich) from comment #1)
> Hey UX, thumbs up or down on this?

Thumbs up. This makes sense. We do the same for email when new notifications come in. Omega, is this something you could consider for the bluetooth backlog?
Flags: needinfo?(rmacdonald)
Flags: needinfo?(ofeng)
Flags: needinfo?(jsavory)
Thumbs up. ni? Jenny for more merging details.
Flags: needinfo?(ofeng) → needinfo?(jelee)
Thumbs up!
There should be only one notification coming from the same app for the same purpose (ex. no matter how many email you receive, there will only be one "email received" notification from email app). However, instead of replacing the previous ones, we should compile a message that reflects the transfer status, in this case, indicate the number of files received in the message:
----------------------------------------
(first line)  File received via bluetooth
(second line) 3 transfer complete
----------------------------------------
Tapping on the notification goes to download manager, user can then access each file from there.

Flagging Ian to comment more on this. Thank you Ian!
Flags: needinfo?(jelee) → needinfo?(iliu)
(In reply to Jenny Lee from comment #7)
> Thumbs up!
> There should be only one notification coming from the same app for the same
> purpose (ex. no matter how many email you receive, there will only be one
> "email received" notification from email app). However, instead of replacing
> the previous ones, we should compile a message that reflects the transfer
> status, in this case, indicate the number of files received in the message:
> ----------------------------------------
> (first line)  File received via bluetooth
> (second line) 3 transfer complete
> ----------------------------------------
Thumbs up! Since WebAPI Notification is ready, we are able to replace and combine the notifications which are notified before. For overall behaviour of Bluetooth transfer, we have to considerate send/receive file(s). And the confirmation of incoming transfer request, progress bar, and multiple files transferring case. There will be more user story than Email, SMS apps on notification interaction, if we want to combine all of Bluetooth transfer notifications.
> Tapping on the notification goes to download manager, user can then access
> each file from there.
For download manager, I think it's possible to integrate the result(s) of Bluetooth transferred file(s) to Settings::Downloads. We will need more information to figure out how we will manage these transferred file(s). As above behavior mentioned, it could have a Bluetooth file transfer management in some where. Not sure that it's a good way to put downloads file(s), Bluetooth transfer file(s) in the same menu. Add Cristian to join the discussion. Thanks :)
Flags: needinfo?(iliu) → needinfo?(crdlc)
Hi,

   The only way to show those files on the download manager list is saving them in our datastore

https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/download/download_notification.js#L134
https://github.com/mozilla-b2g/gaia/blob/master/shared/js/download/download_store.js

   Maybe you could create a download object as the datastore expects so I think that files could be displayed in the download manager list. Further info, please contact to Francisco or Borja who did that part

https://github.com/mozilla-b2g/gaia/blob/master/shared/js/download/download_store.js#L219
Flags: needinfo?(crdlc)
blocking-b2g: --- → backlog
Duplicate of this bug: 1090877
blocking-b2g: backlog → ---
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.