Closed Bug 988156 Opened 6 years ago Closed 6 years ago

Netflix appears black in fullscreen (using Silverlight)

Categories

(Core :: Plug-ins, defect, major)

All
macOS
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox28 --- unaffected
firefox29 + verified
firefox30 + verified
firefox31 + verified

People

(Reporter: austinlhammer, Assigned: mstange)

References

Details

(Keywords: regression, top100)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140318013849

Steps to reproduce:

Watch a show on netflix with silverlight plugin, click the netflix UI fullscreen button.


Actual results:

Entire screen is black with no video working, audio works just fine.
Reporter, could you please test:
1) In safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
2) With a new profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Same issue?

Also, is Silverlight plugin up to date? To verify this, please navigate to http://www.mozilla.org/en-US/plugincheck/. Thanks!
Flags: needinfo?(austinlhammer)
Silverlight is up to date. Happens in safe mode. Happens with a new profile. Same Issue. Also confirmed on a friends computer with same version of firefox (29 beta)
Flags: needinfo?(austinlhammer)
Reporter: Are you having any problems on Firefox Release, Aurora, or Nightly?
Flags: needinfo?(austinlhammer)
I can reproduce this with todays nightly, and have been for at least a week or so. I'm using silverlight version 5.1.20913.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Updating to version 5.1.30214.0 of silverlight (which appears to be the latest as of right now) does not help. I.e. the problem still reproduces.
(In reply to Jonas Sicking (:sicking) from comment #4)
> I can reproduce this with todays nightly, and have been for at least a week
> or so. I'm using silverlight version 5.1.20913.0

Could you please also check Fx 28 RC: http://www.mozilla.org/en-US/firefox/new/ ?
Flags: needinfo?(austinlhammer)
Things appear to work fine with FF28.
(In reply to Jonas Sicking (:sicking) from comment #7)
> Things appear to work fine with FF28.

Jonas, could you please look for a regression window? It would be much appreciated!
Here you find all the details: https://quality.mozilla.org/docs/bugzilla/guide-to-triaging-bugs-for-firefox/finding-a-regression-window/
Thanks in advance!
Component: Untriaged → Plug-ins
Product: Firefox → Core
Version: 29 Branch → Trunk
Nightly regression range:
Last good revision: 4da3e21a0e5f (2014-01-28)
First bad revision: 7e79536aca0a (2014-01-29)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4da3e21a0e5f&tochange=7e79536aca0a

I confirmed this is broken on beta 29 so marking for tracking. Inbound regression range coming soon.
Keywords: top100
Hardware: x86 → All
Summary: netflix fullscreen goes black → Netflix appears black in fullscreen (using Silverlight)
Inbound:
Last good revision: 95b42ba6b1d7
First bad revision: fd0d0f6002dc
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=95b42ba6b1d7&tochange=fd0d0f6002dc

This was very likely caused by bug 846566 since that was about fullscreen plugins on HiDPI and I'm testing on a HiDPI display.
Assignee: nobody → mstange
Blocks: 846566
Status: NEW → ASSIGNED
Markus, could you have a look to this bug for 29? Thanks
Flags: needinfo?(mstange)
Um, we're running out of time here and I don't think we should ship a top100 regression in release…

Steven, what is the effect of backing out bug 846566? Is that worse than Netflix basically not working?
Severity: normal → major
Flags: needinfo?(smichaud)
Keywords: regression
I'd say this bug is far worse than bug 846566.

But (as far as I can tell) nobody's done an hg bisect on the regression ranges from comment #9 and comment #10.  Let me do that quickly and report back.
Thanks. FYI, I will going to wait for a fix here before launching the gtb of beta9.
Sigh, I can't reproduce this bug.

I'd say just back out the patch for bug 846566.  That's probably the best choice considering the little time we have to decide.
Flags: needinfo?(smichaud)
Comment on attachment 8408558 [details] [diff] [review]
Beta backout of bug 846566

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 846566
User impact if declined: Netflix (and possibly other Silverlight?) users will see a black screen when going fullscreen.
Testing completed (on m-c, etc.): Local beta build in progress
Risk to taking this patch (and alternatives if risky): Simple backout to Info.plist
String or IDL/UUID changes made by this patch: None
Attachment #8408558 - Flags: approval-mozilla-beta?
Attachment #8408558 - Flags: review?(smichaud) → review+
Attachment #8408558 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
In order to verify this, test around Silverlight and Flash video, in different sites, in different modes (fullscreen vs in page), across platforms, on normal and HiDPI resolution screens.

Matthew, Steven, please let me know what other testing we can do around this.
QA Whiteboard: [qa+]
Back this out on mozilla-central and aurora as well. No need to leave nightly/aurora testers with a broken netflix.
I now have access to Mozilla QA's Netflix testing account, and can repro this bug while streaming a movie over Netflix.  But I haven't been able to find any other Silverlight examples with which I can repro.  So testing should be limited to Netflix.

I also tested a m-c universal build with bug 846566 backed out, and found that it *does* fix this bug.  Which is pretty weird ... but OK.  It also means that both this bug and bug 846566 are likely to be Silverlight bugs, and that we may never be able to fix bug 846566.

Note that you need to test with a universal build, since Silverlight is 32-bit-only and you should really be running Firefox in 64-bit mode.
If this happens only with netflix and not other silverlight plugins, then it sounds like a netflix bug or at least something that netflix could work around.

However I still think that we should back the regressing patch out from all branches until we have something that works. Regressions should never linger in the tree, that's why we always back out patches that turn tests orange.
yes, marking tracking to get this backed out on those branches as well.
We have performed some testing using Firefox 29 Beta 9 (Build ID:  20140417185217), by verifying behavior of Flash and Silverlight videos in normal and fullscreen mode, covering also Netflix.  We did not encounter any issue (other than a couple of already known other ones). 

Note that we do not have any Retina devices, so we can NOT verify that. 

Testing covered: Netflix, plus other Silverlight sites and Flash sites (https://etherpad.mozilla.org/australis-b9). 
OS covered: Win 8.1 x64 (Surface Pro 2, HiDPI), Win 7 x64, Mac OS X 10.9.2, Ubuntu 13.10 x86.

Could someone who had this issue try it with the latest Firefox 29 Beta 9 (ftp://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/29.0b9-candidates/build1/)?
Attachment #8408998 - Flags: review?(spohl.mozilla.bugs)
> Could someone who had this issue try it with the latest Firefox 29 Beta 9
> (ftp://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/29.0b9-candidates/build1/)?

I just tested it with this bug's STR, on Netflix, and didn't see the bug.

I still do see the bug with FF 29b8.

I tested on a Retina MacBook Pro.
Attachment #8408998 - Flags: review?(spohl.mozilla.bugs) → review+
Comment on attachment 8408998 [details] [diff] [review]
Backout bug 846566 on trunk

The patch for bug 846566 was a hack (a small change to plugin-container.app's Info.plist) that somehow changed the Silverlight plugin's behavior.  We don't know why it worked, and it really shouldn't have made any difference.  But apparently, though it improved Silverlight's behavior in one small respect (it "fixed" bug 846586), it also made Silverlight behave much worse in another, much more important respect (it triggered this bug).

The pre-bug 846566 plugin-container.app Info.plist has been in use for a long time, with no reported problems.  There should be very little risk in going back to it.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 846566
User impact if declined: Netflix is basically unusable on HiDPI displays on OS X 10.9
Testing completed (on m-c, etc.): Considerable testing on beta
Risk to taking this patch (and alternatives if risky): Very low
String or IDL/UUID changes made by this patch: none
Attachment #8408998 - Flags: approval-mozilla-aurora?
I verified this using Fx29b9 candidates, using a Macbook with Retina display by navigating to Netflix and playing movies in fullscreen mode. Fx29b8 did not work, but beta 9 does. I then tried a number of other sites, most of them which use Flash, but also the iTunes trailers site, and all of them played well.

Bug 846566 came back, as expected, so the player controls on Flash using the Retina display look pixelated, but otherwise the videos themselves played well.
https://hg.mozilla.org/mozilla-central/rev/b91748a1b6da
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mstange)
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Attachment #8408998 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1000665
Juan, do you think someone from your side could also verify this on 30 and 31, since we do not have any Retina devices on our side.
Flags: needinfo?(jbecerra)
Verified this using MB with Retina display using latest Silverlight and latest FX 30, 31, 32. Videos on Netflix play fine in default and full screen mode.
Flags: needinfo?(jbecerra)
Keywords: verifyme
Marking as Verified as per comment 34.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
I am experiencing this problem when it has been reported fixed.  This is the
first time I have experienced this and it happened after the most recent updates
of Firefox, Aurora and Nightly.  I have all three browsers installed on my system.
Can you file a new bug about your issue please with more details on your system and the versions?
You need to log in before you can comment on or make changes to this bug.