Closed Bug 988519 Opened 7 years ago Closed 7 years ago

[Camera] Improve localization

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.4 verified, b2g-v2.0 verified)

VERIFIED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- verified
b2g-v2.0 --- verified

People

(Reporter: flod, Assigned: wilsonpage)

References

Details

(Keywords: late-l10n)

Attachments

(3 files)

We should definitely add a localization note for this one
> mp = MP
It stands for megapixels, isn't it?

> Auto, on, off
Are these specific for flash status?

One last question: is there a wireframe available to see how these strings are used? I'm not sure I can test them on a Keon, and I'm scared but these 3 strings.
Flags: needinfo?(wilsonpage)
(In reply to Francesco Lodolo [:flod] from comment #0)
> I'm not sure I can test them on a Keon, and I'm scared but these 3 strings.
…about these 3 strings

To explain: I'm scared that the UI will explode with long localizations.

Like 
en-US: on|off|auto
fr: Activé|Désactivé|Automatique
I believe it should be OK. Currently these string are used in places where they have the entire width of the viewport available.

1. In the settings menu (full width)
2. In the toast style notifications (full width)
Flags: needinfo?(wilsonpage)
Attached image settings.png
Attached image settings-sub.png
Attachment #8397768 - Flags: feedback?(francesco.lodolo)
Comment on attachment 8397768 [details]
settings.png

Thanks, screenshots definitely help: we don't have a problem with the width (great!), but we have other problems.

Namely:
* I expect locales to need adapting on/off to the associated item (gender), this doesn't work with 3 shared strings across features. Is there any chance that we can switch to a graphical switch element for at least on/off values (i.e. not self-timer, which I guess will use also 3 seconds, etc.)? The alternative is to have 2 or 3 strings for each feature. For example: hdr_on, hdr_off, not sure where auto is used (flash?).
* text-transform: uppercase is bad and shouldn't be used (bug 830002). If you want ON/OFF/AUTO, please just put that in the string.
Attachment #8397768 - Flags: feedback?(francesco.lodolo) → feedback-
Blocks: 983405
Assignee: nobody → wilsonpage
Keywords: late-l10n
Summary: [Camera] Add localization notes to new strings → [Camera] Improve localization
Attached file pull-request (master)
Attachment #8398020 - Flags: review?(dmarcos)
Attachment #8398020 - Flags: review?(dmarcos) → review+
Attachment #8398020 - Flags: feedback?(francesco.lodolo)
Comment on attachment 8398020 [details] [review]
pull-request (master)

Thanks, strings look good now. Thanks for updating the comment.
Attachment #8398020 - Flags: feedback?(francesco.lodolo) → feedback+
One note for the future: in this specific case I considered it OK, but as a general rule you should never change a string already landed in master without using a new ID
https://developer.mozilla.org/en-US/docs/Making_String_Changes
flod: Makes sense. Thanks for the heads-up :)
Same comment above is valid for bug 948263 (normally I would file a follow-up bug to replace the string IDs, since it's the only way to ensure localization is up to date with new content).
Landed on 'master'
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
https://github.com/mozilla-b2g/gaia/commit/f978c6b9ade26fe170608a0992682b2dd2616689 is the commit.

Is this intended for 1.4? If so, today is hard string freeze.
pike: Yes this will likely be uplifted to 1.4. Are there any issues?
As I explained on IRC yesterday, it basically means that all these bugs should land on 1.4 before the end of the day, and I'm not sure how it could happen if none of the bugs have been triaged for uplift (or at least I couldn't find any with blocking-b2g set to 1.4? or 1.4+). 

late-l10n is just a mere note that a bug contain string changes that could land late in the cycle, it has nothing to do with uplift approvals.
This is part of the Madai project that is going to be shipped on 1.4 for one of our partners. Adding Hema for additional clarifications.
Flags: needinfo?(hkoka)
Please read the landing procedure for 1.4, https://wiki.mozilla.org/Release_Management/B2G_Landing#v1.4.0. Madai isn't exempt from per-bug approvals. If your bugs aren't 1.4+, they're not landing.

If you have a problem getting your strings landed today, please escalate to b2g-release-drivers immediately. String freeze today is documented on https://wiki.mozilla.org/FirefoxOS/devlifecycle, fwiw.
Reverted for gaia-unit test failures:
https://tbpl.mozilla.org/php/getParsedLog.php?id=36867461&tree=B2g-Inbound

04:16:45     INFO -  gaia-unit-tests TEST-END   | camera/test/unit/controllers/settings_test.js | SettingsController#onOptionTap()
04:16:45     INFO -  gaia-unit-tests TEST-START | camera/test/unit/controllers/settings_test.js | SettingsController#notify()
04:16:45     INFO -  gaia-unit-tests TEST-UNEXPECTED-FAIL | camera/test/unit/controllers/settings_test.js | controllers/settings SettingsController#notify() Should display a notification | this.l10n is undefined
04:16:45     INFO -  gaia-unit-tests INFO       | stack trace:
04:16:45     INFO -      TypeError: this.l10n is undefined
04:16:45     INFO -          at notify (http://camera.gaiamobile.org:8080/js/controllers/settings.js:113:1)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/test/unit/controllers/settings_test.js:78:7)
04:16:45     INFO -          at wrapper (http://camera.gaiamobile.org:8080/common/test/mocha_generators.js:62:13)
04:16:45     INFO -          at run (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709:7)
04:16:45     INFO -          at runTest (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4081:5)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4127:7)
04:16:45     INFO -          at next (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4007:7)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4016:7)
04:16:45     INFO -          at next (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3964:16)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3979:7)
04:16:45     INFO -          at done (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3700:5)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3712:9)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/common/test/mocha_generators.js:46:13)
04:16:45     INFO -          at wrapper (http://camera.gaiamobile.org:8080/common/test/mocha_generators.js:73:15)
04:16:45     INFO -          at run (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3709:7)
04:16:45     INFO -          at next (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3973:5)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:3984:5)
04:16:45     INFO -          at (anonymous) (http://camera.gaiamobile.org:8080/common/vendor/mocha/mocha.js:4932:28)
04:16:45     INFO -  gaia-unit-tests TEST-END   | camera/test/unit/controllers/settings_test.js | SettingsController#notify()

https://github.com/mozilla-b2g/gaia/commit/112f19846cb3e3fdf5ac3db6e5d6b4b1ea16ca6d
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Adding Tiffanie and myself to this bug, since we wrote strings but were not aware of this bug.
Working with Axel via email on Madai Camera localization
Flags: needinfo?(hkoka)
Bulk edit for camera bugs.

If earlier comments do not show how this bug landed to master, it probably landed as part of https://github.com/mozilla-b2g/gaia/pull/17599 which merged the camera-new-features branch into master.

This bug was uplifted from master to v1.4 as part of https://github.com/mozilla-b2g/gaia/commit/a8190d08e61316a86bba572ba8d894d081a20530
Target Milestone: --- → 1.4 S5 (11apr)
blocking-b2g: --- → 1.4+
The issue is fixed on 1.4 and master build.
Localization is improved (ON/OFF, Auto)

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140411000202
Gaia: 6c50349f41d40ba175ea0fc0c2c2cbd739ba7170
Gecko: 28b419f0e857
Version: 30.0a2
Firmware Version: v1.2-device.cfg

1.5 Environmental Variables:
Device: Buri 1.5 Master
BuildID: 20140411040203
Gaia: 1368d716072adf308e1b435ac828f97545a045f1
Gecko: d8c1b10c3a3d
Version: 31.0a1
Firmware Version: v1.2-device.cfg
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.