Closed Bug 988527 Opened 6 years ago Closed 6 years ago

End of progress bar is offset by 1px

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- verified
firefox30 --- verified
firefox31 --- verified
fennec 29+ ---

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

(Keywords: reproducible)

Attachments

(3 files)

Attached image screenshot.png
See screenshot.

GT-P1000N, Android 2.2.
Is this limited to the device and android 2.2?
As far as I know. I haven't been able to reproduce on anything else (though I haven't tested many devices).
This is also present on HTC Desire S (Android 2.3.3) with the Tinderbox Beta build.  
http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-beta-android/1395862133/
Don't see this on Android 4.3/4.4
Assignee: nobody → bnicholson
tracking-fennec: ? → 29+
Looks like the problem here is bad assets: the extra space above and below the progress bars are not balanced. For example, in our MDPI image, the distance between the top of the image and the top of the progress bar is 9x; the distance between the bottom of the progress bar and the bottom of the image is 8px. When the image is scaled, this results in slightly more weight at the bottom of the image, causing the bulb to be misaligned.

To fix this, I just added an extra pixel to top left border of the 9png, which effectively subtracts 1px from the top non-stretchable padding area. This makes the bottom and top non-stretchable padding areas equal.
Attachment #8398080 - Flags: review?(lucasr.at.mozilla)
Spotted on my Nexus S (2.3)
Keywords: reproducible
Just to be clear what I'm referring to, here's a before/after of the MDPI image (at 10x scale). Similar changes needed to be made to the HDPI and XHDPI assets.
Aaron, Can you confirm that this build works as expected on your Nexus S and other devices? http://people.mozilla.org/~bnicholson/fennec_builds/progress-bar-10.apk
Flags: needinfo?(aaron.train)
WFM
Flags: needinfo?(aaron.train)
Comment on attachment 8398080 [details] [diff] [review]
Fix progress.9.png to have balanced padding

Review of attachment 8398080 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch.
Attachment #8398080 - Flags: review?(lucasr.at.mozilla) → review+
Comment on attachment 8398080 [details] [diff] [review]
Fix progress.9.png to have balanced padding

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 962103
User impact if declined: progress bar tip is offset by 1px; see screenshot
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): very low risk; only changes images, not code
String or IDL/UUID changes made by this patch: none
Attachment #8398080 - Flags: approval-mozilla-beta?
Attachment #8398080 - Flags: approval-mozilla-aurora?
Triage drive by: we'll hold off on marking status fixed (and approving uplifts) until this lands on central without issue.
https://hg.mozilla.org/mozilla-central/rev/194b624cdec5
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Status: RESOLVED → VERIFIED
Attachment #8398080 - Flags: approval-mozilla-beta?
Attachment #8398080 - Flags: approval-mozilla-beta+
Attachment #8398080 - Flags: approval-mozilla-aurora?
Attachment #8398080 - Flags: approval-mozilla-aurora+
Verified fixed on Aurora 30.0a2 (2014-04-02)

Still needs to be verified on Firefox 29 Beta 6
Verified fixed on Firefox 29 Beta 6
You need to log in before you can comment on or make changes to this bug.