Closed Bug 988656 Opened 7 years ago Closed 7 years ago

[B2G][Camera] Thumbnails persist after the target is deleted through Gallery

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: pcheng, Unassigned)

Details

(Keywords: regression, Whiteboard: burirun1.4-2 [WFM-on-master])

Attachments

(3 files)

Attached video video of issue occurred
Description:
The thumbnails at the top of the screen do not disappear after their targets are deleted from the Gallery app while the Camera app remains open

Repro Steps:
1) Update a Buri to BuildID: 20140326000201
2) Launch the Camera app
3) Take a picture
4) Tap on Gallery icon at bottom to access the Gallery
5) Delete the picture taken at step 3
6) Tap on Camera icon at bottom to go back to Camera
7) Bring up the Thumbnails strip at the top

Actual:
The deleted picture at step 3 appears at the top

Expected:
The deleted picture at step 3 does not appear at the top

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140326000201
Gaia: 7e705dd4718d528974d99ac31866318d7e201152
Gecko: 4889124accfa
Version: 30.0a2
Firmware Version: v1.2-device.cfg


Notes:
Repro frequency: (3/3)
See attached video and logcat.
Attached file Logcat
Attaching logcat.
This issue does not reproduce on the 3/26/14 1.3 build.

Device: Buri v1.3 MOZ
BuildID: 20140326004002
Gaia: 812838ad0fabf51fa14435af562ddac6d26fa936
Gecko: ba97efb0da4b
Version: 28.0
Firmware Version: v1.2-device.cfg
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
This fails test case ID 2852
Whiteboard: burirun1.4-2
What happens if you click on picture in the filmstrip?
Keywords: qawanted
Attached image video file screenshot
Two things can happen when attempting to view deleted items from filmstrip.

1) If it's a video file, it displays a broken video UI. Screenshot of that is attached.

2) If it's a picture file, the app exits out itself which appears to be OOM.
Keywords: qawanted
Can confirm this. Camera crashes to homescreen 5/5 times when thumbnail is clicked. No crash report.

dmesg snippet (OOM?):
<4>[  317.017356] select 656 (Camera), adj 10, size 6679, to kill
<4>[  317.017373] send sigkill to 656 (Camera), adj 10, size 6679

Environmental Variables:
Device: Buri v1.4 Mozilla RIL
BuildID: 20140326000201
Gaia: 7e705dd4718d528974d99ac31866318d7e201152
Gecko: 4889124accfa
Version: 30.0a2
Firmware Version: v1.2-device.cfg
Okay - if we're crashing & displaying broken UX, then this is pretty bad.
blocking-b2g: --- → 1.4?
Marcia: Please test this out on master
Flags: needinfo?(mozillamarcia.knous)
blocking because it is regression
blocking-b2g: 1.4? → 1.4+
QA Contact: jzimbrick
I don't see this using the latest master on Buri:

Gaia   26839cb46f856d610b192f5655a8c38a6bfe0829
SourceStamp d8e8f13bd4ae
BuildID 20140331040200
Version 31.0a1

Since there is a new preview flow I checked both the preview flow next to the shutter button as well as deleting pictures from Gallery itself. In both cases the picture was deleted properly.
Flags: needinfo?(mozillamarcia.knous)
Issue first occurs in 12/23 build. In earlier builds, the picture is no longer displayed in the filmstrip after being deleted from gallery.

Last Working Environmental Variables:
Device: Buri
BuildID: 20140122040205
Gaia: 8d18b1e2fd06c84a879f99f6e8ca1f104eeacb13
Gecko: 8f4ecbf938cd
Version: 29.0a1
Base Image: V1.2-device.cfg

First Broken Environmental Variables:
Device: Buri
BuildID: 20140124040404
Gaia: 290efee3de3a12c9d803f4650d50bc7c7a8e1f2d
Gecko: 9d650c07b547
Version: 29.0a1
Base Image: V1.2-device.cfg
Apologies, posted the wrong environmental variables in the previous comment. Here are the correct window variables.

Last Working Environmental Variables:
Device: Buri v1.4 Moz RIL
BuildID: 20140122040205
Gaia: 8d18b1e2fd06c84a879f99f6e8ca1f104eeacb13
Gecko: 8f4ecbf938cd
Version: 29.0a1
Base Image: V1.2-device.cfg

First Broken Environmental Variables:
Device: Buri v1.4 Moz RIL
BuildID: 20140123040608
Gaia: 00d8d05f0d0730a3cbf17635ad6a6b197a2ce7c9
Gecko: 1a75d37e1e39
Version: 29.0a1
Base Image: V1.2-device.cfg
RIL Version: 01.02.00.019.102

Gecko/Gaia and pushlog will be posted shortly
Leaving the window request here until we get the push logs.
(In reply to rkuhlman from comment #14)
> This is a Gecko issue.
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=8f4ecbf938cd&tochange=1a75d37e1e39

This can be reduced further - I'm seeing multiple pushes here. Can you use tinderbox m-c builds to reduce this further?
Whiteboard: burirun1.4-2 → burirun1.4-2 [WFM-on-master]
I worked with rkuhlman to find a new regression window for this issue. 

Unfortunately, this issue was introduced earlier than we have tinderbox builds available, so this window is still using nightly builds. 

Nightly Regression Window:

Last Working Environmental Variables:
Device: Buri
BuildID: 20140116040206
Gaia: 82878ba16172213cd00ba3e8b37756
4b290e59c1
Gecko: 324e2cba1029
Version: 29.0a1
Base Image: V1.2-device.cfg

First Broken Environmental Variables:
Device: Buri
BuildID: 20140117041037
Gaia: ef8bb31b462f364b57432a0724c78034d3f4f303
Gecko: b53589696cf8
Version: 29.0a1
Base Image: V1.2-device.cfg

Last Working Gaia / First Broken Gecko: Issue does NOT reproduce.
Gaia: 82878ba16172213cd00ba3e8b377564b290e59c1
Gecko: b53589696cf8

First Broken Gaia / Last Working Gecko: Issue DOES reproduce.
Gaia: ef8bb31b462f364b57432a0724c78034d3f4f303
Gecko: 324e2cba1029

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/82878ba16172213cd00ba3e8b377564b290e59c1...ef8bb31b462f364b57432a0724c78034d3f4f303
(In reply to Marcia Knous [:marcia - use needinfo] from comment #10)
> I don't see this using the latest master on Buri:
> 
> Gaia   26839cb46f856d610b192f5655a8c38a6bfe0829
> SourceStamp d8e8f13bd4ae
> BuildID 20140331040200
> Version 31.0a1
> 
> Since there is a new preview flow I checked both the preview flow next to
> the shutter button as well as deleting pictures from Gallery itself. In both
> cases the picture was deleted properly.


Please verify - new camera features landed today. Marking this fixed
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Marcia - Can you check if this works fine with 1.4 with the new camera new features branch?
Flags: needinfo?(mozillamarcia.knous)
Target Milestone: --- → 1.4 S5 (11apr)
(In reply to Jason Smith [:jsmith] from comment #18)
> Marcia - Can you check if this works fine with 1.4 with the new camera new
> features branch?

Works fine with me on Buri using:

Gaia   b4f3b84ec68233a99fd5865c15cfe28aebe26531
SourceStamp 3186bbc50050
BuildID 20140404000202
Version 30.0a2
Flags: needinfo?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.