Closed Bug 988749 Opened 7 years ago Closed 7 years ago

[tarako][perf] Email app stopped when attaching a large picture(600K) from Camera

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect, P1)

Other
Other
defect

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified, b2g-v1.4 fixed, b2g-v2.0 fixed)

VERIFIED FIXED
1.4 S5 (11apr)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: angelc04, Assigned: asuth)

References

Details

(Whiteboard: [priority][c= p=1])

Attachments

(1 file)

Attached file ADB logcat
* Build info:
Gaia d8ff994bd96c37ba9a93c343932a5441a78a0eec
Gecko 6db37b3f76b4fe2aa6f8fb5ae9e036ed99344772
BuildID 20140327060053
Version 28.1
ro.build.version.incremental=69
ro.build.date=Thu Mar 27 06:07:07 CST 2014

* Steps to reproduce:
1. Launch Email
2. Add a new email
3. Tap on Add attachment and select Camera
4. Take a picture larger than 600K. (you can take pic of some object which has rich colors.)
5. Select the pic just took in step 5
   --> You will see that Email exit after attaching the pic to Email

* adb logcat. Tests starts at: 03-27 15:04:18.633
Thank you for the logcat!

This indicates that this is one of the variations of the problems witnessed in v1.4 for bug 981010 which was solved by bug 949941.  Bug 949941 needs a v1.3T (well, really v1.3, but v1.3 probably won't take it I guess) uplift to finish being prepared to address the problem.  (There is also clearly some type of underlying platform issue, but we really want bug 949941 for memory reasons too on Tarako, so let's do that.)

Let's leave this bug open/not duped since it serves as a good 1.3T place-holder to track the need to complete that work.  (And 981010 was only a placeholder bug anyways.)

I should be able to get to finishing the 1.3T patch and testing it by the end of this week, but I'm going to leave this unassigned for now in case anyone else wants to pick it up first.
blocking-b2g: --- → 1.3T?
Oddly enough, I am finding that, although I'm crashing the first time on occasion, by adding more and more large attachments, mail app is nonetheless able to stand up, and I can send the mail.   I'd like to see how this currently looks on master.
Ok, checked this also on Master.  The Picture from Camera actually attaches.  The mail is never sent (but that's another issue :)
:asuth, do we have a spec defining what is the maximum size of a pic that can be added as an attachment ? And do we through an error if the size limit exceeds?
(In reply to bhavana bajaj [:bajaj] from comment #4)
> :asuth, do we have a spec defining what is the maximum size of a pic that
> can be added as an attachment ? And do we through an error if the size limit
> exceeds?

See https://wiki.mozilla.org/Gaia/Email/Features#Sending_Attachments for details by version and such, but short answer:

Current limit for all attachments in total on a message is ~5 MiB, we will refuse to add whatever attachment pushes us over that limit and display a message.  As I indicate in comment 1, this is categorically a platform issue that has been worked-around in gaia in bug 949941 and that needs the completed patch to be uplifted.
triage: 1.3T+ for a common use case.
Andrew, do you think you can prepare a patch and uplift bug 949941 to 1.3T? Thanks
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(bugmail)
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
Flags: needinfo?(bugmail)
Target Milestone: --- → 1.4 S5 (11apr)
Whiteboard: [priority]
Severity: normal → blocker
Priority: -- → P1
As noted in https://bugzilla.mozilla.org/show_bug.cgi?id=949941#c29:

The patch for bug 949941 has been backported to v1.3t and landed in gaia/v1.3t:
https://github.com/mozilla-b2g/gaia/pull/17136
https://github.com/mozilla-b2g/gaia/commit/99890f3d9309ed5c696e110533aea5b6281f65d6
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [priority] → [priority][c= p=1]
Looks well, no side effect.

[Environment]
Gaia      553da99ab09b6b894d9f95bb06b16b6e1ddbf0a1
Gecko     https://hg.mozilla.org/mozilla-central/rev/5b6e82e7bbbf
BuildID   20140414160205
Version   31.0a1
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013

[Result]
PASS
Status: RESOLVED → VERIFIED
Verified on the latest Tarako build

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

1.3 tarako: Email does not exit after attaching the pic to Email
You need to log in before you can comment on or make changes to this bug.