Closed Bug 988836 Opened 6 years ago Closed 6 years ago

network.http.spdy.enabled.http2draft problem

Categories

(Core :: Networking: HTTP, defect)

31 Branch
x86
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ale160382, Unassigned)

References

Details

(Whiteboard: [spdy])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140327030203

Steps to reproduce:

i m really disgusted after today update i coul not use any google services(got connection was reset message) i wasted 2 hours of my time just to find out a sipmle setting was causing this :
network.http.spdy.enabled.http2draft;true
really firefox do to hell once for all!
Component: General → Networking: HTTP
OS: Mac OS X → All
Hi alessandro -

Thanks for running the nightly channels - it helps us make the internet better. It sounds like you're a little frustrated with the uneven experience of running development builds. If you need the most stable experience then please run the release channels and do not adjust the default configuration.

I can confirm your problem this morning.

Yesterday we landed http2 udpates (this protocol is disabled by default) to draft 10. It turns out that google.com is offering to negotiate h2-10 and that we were unaware of this, so hadn't tested with them. (its a new development for them too).

google.com is responding to our first HEADERS frame with a GOAWAY frame error code 1 (PROTOCOL ERROR) and additional data of "invalid_new_stream_id".

We use stream id 0x3 for the first stream, which I believe is ok (unless something has changed on the spec side). I'll sort it out with the google folks and get us interopping.

Thanks.
Whiteboard: [spdy]
Duplicate of this bug: 988968
Status: UNCONFIRMED → NEW
Ever confirmed: true
google.com folk say "known issues that we're working with  :-)" .. so waiting for the moment is the right call.
another problem:

steps:
- set network.http.spdy.enabled.http2draft;true && security.ssl.enable_alpn;true
- GET https://twitter.com

actual result:
HTTP/1.1 200 OK

expected:
HTTP/2.0 200 OK
Blocks: 965869
(In reply to Ekanan Ketunuti from comment #4)
> another problem:
> 
> steps:
> - set network.http.spdy.enabled.http2draft;true &&
> security.ssl.enable_alpn;true
> - GET https://twitter.com
> 
> actual result:
> HTTP/1.1 200 OK
> 
> expected:
> HTTP/2.0 200 OK

This is to be expected, as it does not appear that twitter is advertising h2-10 yet, only draft09.
twitter and Firefox nightly now interop fine on h2-12...
and google is not running h2-12 at all. so this bug is closed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.