Closed Bug 988852 Opened 7 years ago Closed 7 years ago

Gaia Test Failure with waiting for homescreen...

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S4 (28mar)

People

(Reporter: cbook, Assigned: mcav)

Details

(Whiteboard: [p=1])

Somehow after the backout of a gaia unit test regression in https://hg.mozilla.org/integration/b2g-inbound/rev/b9b59eaca8d5 the marionette tests are failing like https://tbpl.mozilla.org/php/getParsedLog.php?id=36797038&tree=B2g-Inbound

06:09:51     INFO -  waiting for system-message-listener-ready...
06:09:51     INFO -  ...done
06:09:53     INFO -  waiting for homescreen...
06:11:55     INFO -  Traceback (most recent call last):

no idea by what this is caused and how a backout can cause something like this. Investigating with folks in #gaia
Root cause: Git did not revert the change to apps/system/js/bootstrap.js because a subsequent commit already removed the line that the reverted commit added. The dependent commit that needed to be backed out was here:

https://github.com/mozilla-b2g/gaia/commit/5b499bc5ffbc4fe62d90154dc0d3233bcf30ddd0
This was resolved by :tomcat backing out the commit referenced above.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee: nobody → m
Whiteboard: [p=1]
Target Milestone: --- → 1.4 S4 (28mar)
You need to log in before you can comment on or make changes to this bug.