Closed Bug 988853 Opened 6 years ago Closed 6 years ago

Disable Metro builds on secondary configs

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(firefox29+ verified, firefox30+ verified, firefox31 verified)

VERIFIED FIXED
mozilla31
Tracking Status
firefox29 + verified
firefox30 + verified
firefox31 --- verified

People

(Reporter: bbondy, Assigned: bbondy)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #981166 +++
Maybe this is related in some way to the class not registered bug reports.
Attachment #8397831 - Flags: review?(jmathies)
Attachment #8397831 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/integration/fx-team/rev/6ff4b8348f8a
Target Milestone: --- → Firefox 31
Comment on attachment 8397831 [details] [diff] [review]
Disable metro configs on secondary settings - rev1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Metro in general but partial turn off of metro was done in bug 981166
User impact if declined: Some build configs will still have metro on
Testing completed (on m-c, etc.): The parent task is already on m-c and on aurora.
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none

I'd like to get this on aurora today so the build configs are consistent.
Attachment #8397831 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/6ff4b8348f8a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8397831 [details] [diff] [review]
Disable metro configs on secondary settings - rev1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Metro in general but partial turn off of metro was done in bug 981166
User impact if declined: Some build configs will still have metro on
Testing completed (on m-c, etc.): The parent task is already on m-c and on aurora.
Risk to taking this patch (and alternatives if risky): low 
String or IDL/UUID changes made by this patch: none
Attachment #8397831 - Flags: approval-mozilla-beta?
Attachment #8397831 - Flags: approval-mozilla-beta?
Attachment #8397831 - Flags: approval-mozilla-beta+
Attachment #8397831 - Flags: approval-mozilla-aurora?
Attachment #8397831 - Flags: approval-mozilla-aurora+
Kamil, can you please verify this is fixed? We couldn't reproduce it on our end.
Flags: needinfo?(kamiljoz)
Went through the verification for the Nightly channel using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-24-03-02-03-mozilla-central/firefox-31.0a1.en-US.win64-x86_64.installer.exe
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-04-04-03-02-02-mozilla-central/firefox-31.0a1.en-US.win64-x86_64.installer.exe
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/firefox-31.0a1.fa.win32.installer.exe

Went through the following test cases with the x64 builds:

- Ensured that the "Windows 8 Touch" button under the Australis settings menu has been removed
- Ensured that metrofx cannot be added via the Australis configuration menu
- Ensured that the "Relaunch in Nightly for Windows 8 Touch" is removed from the Menu Bar
- Ensured that all the available shortcuts are being launched in desktopfx and don't produce any errors or issues
- Ensured that launching exterior links from other metro applications switch into the desktop environment and correctly launches desktopfx
- Went through two different users accounts and ensured that updating one user didn't cause any issues with the second user (ensured both have been reverted back to metrofx)

Ensured that the following registry entries have been removed after updating:

- HKEY_CURRENT_USER\Software\Mozilla\ (made sure all metro related keys/folders have been removed)
- HKEY_LOCAL_MACHINE\SOFTWARE\Classes\EEFEA8717BC47F65\
- HKEY_USERS\S-1-5-21-1791338240-857805526-2257772433-1002\Software\Classes\EEFEA8717BC47F65\

I couldn't find any l10n builds that still had metrofx enabled so I downloaded the latest l10n and randomly selected a language. I went through the build and ensured that all the metrofx features/buttons/references have been removed.
Went through the verification for the Aurora channel using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-29-00-40-01-mozilla-aurora-l10n/firefox-30.0a2.fa.win32.installer.exe
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n/firefox-30.0a2.fa.win32.installer.exe

I basically went through all the test cases mentioned in comment #9 but couldn't do any of the updater cases for the following reasons:
* it appears that l10n builds only go back 2 weeks (those builds already have metrofx disabled and I couldn't find an older build with metrofx enabled)
* it appears that x64 builds created for m-c builds but the aurora builds only get x64 for "current builds"

Without finding an older build with metrofx enabled, there's no way of me testing the updating features. However I did reproduce the issue and ensured it was fixed using the following test case:

* Downloaded and installed an aurora l10n build before the push in comment #6: (this produced the issue when clicking on the shortcuts)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-28-00-40-01-mozilla-aurora-l10n/
* Downloaded and installed the latest aurora l10n build and issue wasn't occurring anymore

If anyone disagrees marking this as verified for the aurora channel, please change it back and let me know if I missed something!
Flags: needinfo?(kamiljoz)
Went through the verification for the BETA channel using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b3/win32/de/ (metrofx enabled build and than updated to disabled build)
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/29.0b5/win32/de/

* Went through all available test cases in comment #9 without any issues
* Went through all the available test cases in comment #10 without any issues

Please re-open if anyone disagrees with the testing process for this issue.
Status: RESOLVED → VERIFIED
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 31 → mozilla31
You need to log in before you can comment on or make changes to this bug.