Closed Bug 989009 Opened 6 years ago Closed 6 years ago

Australis: Hard to read highlighted label |Open "LiveBookmarks Name"| of LiveBookmarks (Windows7 Classic)

Categories

(Firefox :: Theme, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 + verified
firefox30 + verified
firefox31 + verified

People

(Reporter: alice0775, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3])

Attachments

(3 files)

In Windows7 Classic

Steps To Reproduce:
1. Create a LiveBookmarks
2. Expand the LiveBookmarks from Bookmarks Widget
3. Select |Open "LibeBookmarks Name"| on top of the menupopup

Actual Results:
Hard to read text

Expected Results:
Highlighted text color and background color should be same as other item
Attached image screenshot
This would be P3- but the illegibility makes this worse. :-\
Whiteboard: [Australis:P3]
Attached image screenshot2
Label "LiveBookmark Loading..." is also affected
Summary: Australis: Hard to read highlighted label |Open "LibeBookmarks Name"| of LiveBookmarks (Windows7 Classic) → Australis: Hard to read highlighted label |Open "LiveBookmarks Name"| of LiveBookmarks (Windows7 Classic)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
OS: Windows 7 → All
Hardware: x86_64 → All
This is pretty simple. Marco, look OK to you?
Attachment #8398464 - Flags: review?(mak77)
Comment on attachment 8398464 [details] [diff] [review]
should theme live bookmark submenu items correctly,

Review of attachment 8398464 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/places/content/browserPlacesViews.js
@@ +394,5 @@
>        // Add "Open (Feed Name)" menuitem.
>        aPopup._siteURIMenuitem = document.createElement("menuitem");
> +      let className = "openlivemarksite-menuitem";
> +      if (typeof this.options.extraClasses.entry == "string") {
> +        className += " " + this.options.extraClasses.entry;

why don't you just use classList.add and leave the current code untouched? should make the patch smaller.

@@ +433,5 @@
>        // Create the status menuitem and cache it in the popup object.
>        statusMenuitem = document.createElement("menuitem");
> +      let className = "livemarkstatus-menuitem";
> +      if (typeof this.options.extraClasses.entry == "string") {
> +        className += " " + this.options.extraClasses.entry;

ditto
Attachment #8398464 - Flags: review?(mak77) → review+
w/ classList.add:

remote:   https://hg.mozilla.org/integration/fx-team/rev/6ed1e0ac4f12
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
Comment on attachment 8398464 [details] [diff] [review]
should theme live bookmark submenu items correctly,

(I'm going to be away the coming week, so pre-emptively asking for approval)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis / bookmark menu restyle bugs (bug 969592, bug 969584)
User impact if declined: feed "open feed" and "feed failed to load" items are misstyled everywhere, in some cases they are hard to read (e.g. Windows classic)
Testing completed (on m-c, etc.): local, soon on m-c
Risk to taking this patch (and alternatives if risky): very low, adding a class to these items to bring their styling in line with the other items
String or IDL/UUID changes made by this patch: none
Attachment #8398464 - Flags: approval-mozilla-beta?
Attachment #8398464 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/6ed1e0ac4f12
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 31
Attachment #8398464 - Flags: approval-mozilla-beta?
Attachment #8398464 - Flags: approval-mozilla-beta+
Attachment #8398464 - Flags: approval-mozilla-aurora?
Attachment #8398464 - Flags: approval-mozilla-aurora+
I was able to confirm the fix for this issue on Windows 7 64-bit [1] using:
- the latest Beta (Build ID: 20140331125246),
- the latest Aurora (Build ID: 20140401004001),
- the latest Nightly (Build ID: 20140401030203).

1. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
You need to log in before you can comment on or make changes to this bug.