Closed Bug 989168 Opened 8 years ago Closed 7 years ago

Frequent Linux opt mochitest-dt browser_manifest_editor.js | Test timed out | Found a tab after previous test timed out: about:app-manager

Categories

(DevTools Graveyard :: WebIDE, defect, P1)

Tracking

(firefox30 disabled, firefox31 disabled, firefox33 disabled, firefox34 disabled, firefox35 disabled, firefox-esr31 disabled)

RESOLVED FIXED
Firefox 35
Tracking Status
firefox30 --- disabled
firefox31 --- disabled
firefox33 --- disabled
firefox34 --- disabled
firefox35 --- disabled
firefox-esr31 --- disabled

People

(Reporter: RyanVM, Assigned: jryans)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

With the mochitest-dt suite running on Cedar (the devtools browser-chrome tests running as their own suite), this failure occurred 4/20 times on Linux32 opt runs and 13/20 times on Linux64 opt runs. This is blocking enabling this test suite on trunk.

https://tbpl.mozilla.org/php/getParsedLog.php?id=36840024&tree=Cedar

Ubuntu VM 12.04 cedar opt test mochitest-devtools-chrome on 2014-03-27 16:46:33 PDT for push a0682a0b637c
slave: tst-linux32-spot-250

16:49:14     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | got load event
16:49:14     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Wait for projects panel
16:49:14     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | projectsUI not ready
16:49:14     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Adding sample packaged app
16:49:15     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Wait for projects panel
16:49:15     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | projectsUI ready
16:49:15     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Wait for project selection
16:49:15     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Console message: [JavaScript Error: "not well-formed" {file: "file:///builds/slave/test/build/tests/mochitest/browser/browser/devtools/app-manager/test/manifest.webapp" line: 1 column: 1 source: "{"}]
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Key doesn't match expected value
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Value doesn't match expected value
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Manifest doesn't contain expected value
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Key doesn't match expected value
16:49:15     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Console message: [JavaScript Error: "JSON.parse: unexpected keyword at line 1 column 1 of the JSON data" {file: "chrome://browser/content/devtools/app-manager/manifest-editor.js" line: 67}]
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Value was changed, but it should not have been
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Manifest was changed, but it should not have been
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Found parent element
16:49:15     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Found add-property button
16:49:15     INFO -  *************************
16:49:15     INFO -  A coding exception was thrown and uncaught in a Task.
16:49:15     INFO -  Full message: TypeError: newElem is null
16:49:15     INFO -  Full stack: addNewManifestProperty/<@chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js:120:1
16:49:15     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:298:1
16:49:15     INFO -  resolve@resource://gre/modules/commonjs/sdk/core/promise.js:118:11
16:49:15     INFO -  then@resource://gre/modules/commonjs/sdk/core/promise.js:43:43
16:49:15     INFO -  resolve@resource://gre/modules/commonjs/sdk/core/promise.js:185:11
16:49:15     INFO -  *************************
16:49:15     INFO -  *************************
16:49:15     INFO -  A coding exception was thrown and uncaught in a Task.
16:49:15     INFO -  Full message: TypeError: newElem is null
16:49:15     INFO -  Full stack: addNewManifestProperty/<@chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js:120:1
16:49:15     INFO -  TaskImpl_run@resource://gre/modules/Task.jsm:298:1
16:49:15     INFO -  resolve@resource://gre/modules/commonjs/sdk/core/promise.js:118:11
16:49:15     INFO -  then@resource://gre/modules/commonjs/sdk/core/promise.js:43:43
16:49:15     INFO -  resolve@resource://gre/modules/commonjs/sdk/core/promise.js:185:11
16:49:15     INFO -  *************************
16:49:59     INFO -  Xlib:  extension "RANDR" missing on display ":0".
16:50:01  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Test timed out
16:50:01     INFO -  TEST-INFO | MEMORY STAT vsize after test: 454766592
16:50:01     INFO -  TEST-INFO | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
16:50:01     INFO -  TEST-INFO | MEMORY STAT residentFast after test: 128147456
16:50:01     INFO -  TEST-INFO | MEMORY STAT heapAllocated after test: 45921636
16:50:01     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | finished in 45081ms
16:50:01  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/app-manager/test/browser_manifest_editor.js | Found a tab after previous test timed out: about:app-manager
I'll take a look at this.  What's my best plan for reproducing this environment?  I assume I can't yet run this suite on try?
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Flags: needinfo?(ryanvm)
You should be able to apply patch 1 from bug 984930 and then run |mach mochitest-devtools|.
Flags: needinfo?(ryanvm)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #2)
> You should be able to apply patch 1 from bug 984930 and then run |mach
> mochitest-devtools|.

Maybe I'm doing it wrong, but with that patch |mach mochitest-devtools| gives me:

TEST-UNEXPECTED-FAIL | (browser-test.js) | No tests to run. Did you pass an invalid --test-path?

and fails to actually run any tests.  Any other ideas?

I'll keep looking at the actual test in the mean time...
Flags: needinfo?(ryanvm)
That's really better asked of the guys adding this suite ;)
Flags: needinfo?(ryanvm) → needinfo?(mratcliffe)
For now I'll just go with mochitest-browser, since you'd assume that should essentially be the same.
:jryans, I have updated the patch on bug 984930, this is what we are running on cedar and seeing this problem.  This seems to be a problem on linux 32/64 opt only.
I can't replicate this failure locally in my Linux VM, so I think for now we should proceed by disabling this test on Linux.  Once the new suite is available on try, I can attempt various fixes there to see how they perform.

My current guess is that it is related to a focus issue[1], which Linux is apparently more sensitive about when your test synthesizes keyboard events.

I will note that in the new devtools suite, this test has the lucky honor of being the first test in the suite, so it is possible that by disabling this test on Linux, we may see the same problem with the next test down...  Hopefully that will not be the case though!

[1]: https://developer.mozilla.org/en-US/docs/Mozilla/QA/Avoiding_intermittent_oranges#Tests_which_require_focus
Flags: needinfo?(mratcliffe)
Keywords: leave-open
Let's check in this disable patch for now, and I'll investigate further when Try will let me.
Keywords: checkin-needed
If it's a focus issue, Enn or Ehsan might be able to help too.
RyanVM, do you understand how this test came back to life?  From the manifest[1], it looks like it should still be disabled on Linux.

[1]: http://hg.mozilla.org/mozilla-central/raw-file/c55dfb01a027/browser/devtools/app-manager/test/browser.ini
Flags: needinfo?(ryanvm)
These are on Aurora. I'll disable it there too.
Flags: needinfo?(ryanvm)
RyanVM, did you disable it on Aurora?  I am fine to just ignore these messages too... ;)
Flags: needinfo?(ryanvm)
I don't plan to do anything more here, because this test will be removed as part of bug 1007061 (removing all of App Manager v1).
Depends on: rm-am
Keywords: leave-open
Hmm, alright, I've changed my mind.  This seems to be more frequent now, but we're not yet ready to remove all of App Manager.

I'll disable it.
https://hg.mozilla.org/mozilla-central/rev/138869183b29
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 35
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.