bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Horizontal mousewheel doesn't work

VERIFIED DUPLICATE of bug 58589

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 58589
17 years ago
14 years ago

People

(Reporter: Luca Olivetti, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:0.9.3+) Gecko/20010904
BuildID:    2001090408

As the vertical mousewheel scrolls the document up/down, I'd expect the
horizontal mousewheel to scroll it sideways. Instead it does funny things (such
as selecting the word near the cursor or clicking a link).
The wheel seems to be configured correctly (i.e. I have the relevant 'Option
"ZAxisMapping" "4 5 6 7"' in XF86Config, and it works with programs controlled
by imwheel).

Reproducible: Always
Steps to Reproduce:
1.Verify that X is configured for an horizontal wheel (i.e. 'Option
"ZAxisMapping" "4 5 6 7"' in the mouse section of your XF86Config file)
1a. Verify that the horizontal wheel is working with other applications (e.g.
controlled by imwheel)
2.Open a page with mozilla
3.Resize the window so that is necessary to scroll sideways to see the rest of
the page
4.Use the horizontal wheel to scroll the page sideways

Actual Results:  Words near the cursor are selected (or clicked if they are links)

Expected Results:  Horizontal scrolling of the page
vertical scrolling is currently unsupported..


*** This bug has been marked as a duplicate of 58589 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
s/vertical/Horizontal/

vrfy dupe
URL: any
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.