Privileged apps need a way to set the wallpaper

RESOLVED DUPLICATE of bug 900551

Status

defect
RESOLVED DUPLICATE of bug 900551
5 years ago
5 years ago

People

(Reporter: kgrandon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We are building a replaceable homescreen for gaia. The homescreen should have a way for users to change the wallpaper as they do in the current homescreen. Currently the homescreen does this by writing to the settings API in the key: wallpaper.image

Perhaps one option here would be to use a web activity instead, then have the settings app handle this.
Blocks: vertical-homescreen
No longer blocks: 988401
Hi Vivien, Jonas - what would you suggest the best way to set the wallpaper from a privileged app? Right now you need the settings permission to do this. Two possible implementations may be:

1 - Create a new webAPI for setting the wallpaper.
2 - Proxy the pick activity through the settings app, creating a new pick-wallpaper activity.

Do you guys have any preference in implementation? Thanks!
Flags: needinfo?(jonas)
Flags: needinfo?(21)
Seems like a duplicate of bug 900551 :)

A new API for the background sounds a big hammer.

A new web activity probably does not work as the background needs to be accessed by both the homescreen and the call screen :/

One way could be to have the Settings apps exposed a datastore of some configurable bits and so some other apps can access it.
Flags: needinfo?(21)
Sure, let's dupe it :)
No longer blocks: vertical-homescreen
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 900551
You need to log in before you can comment on or make changes to this bug.