download makes temp file in wrong filesystem

VERIFIED DUPLICATE of bug 55690

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 55690
17 years ago
13 years ago

People

(Reporter: Bob Niederman, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

downloading a file seems to create a temp file of the downloald in /tmp.  This
is bad if I'm dowNloading something bigger than all remaining space in /
filesystem (e.g. an iso image).  Even though I've selected a location where
there IS enough space, mozilla stupidly insists on putting the temp file
soewhwere where there is not enough space.  Why even bother creating a temp
file?  why not just download to where the user said to put the file?  this seems
like unneeded work done badly.

Reproducible: Always
Steps to Reproduce:
1. download any file from anywhere.
2.
3.

Actual Results:  as described

Expected Results:  The file should be created and downloaded to with the NAME
THE USER CHOSE IN THE DIRECTORY THE USER CHOSE.  First rule of UI design: DO
WHAT THE USER ASKS YOU TO DO.  Do not think that you know more than the user. 
YOU DON'T.
> The file should be created and downloaded to with the NAME
> THE USER CHOSE IN THE DIRECTORY THE USER CHOSE

We start asynchronously downloading before the user picks a name location to
speed up downloads.  This often saves the user a certain amount of time...  but
is a PITA at other times (like in your case).

Oh, and having /tmp be in / is usually a bad idea.  Just as a general reference.
 Symlinks are your friend.

Duplicate of "Saving a file creates a file before location is chosen"



*** This bug has been marked as a duplicate of 55690 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Even if /tmp was not in /, this is still an issue.  This isn't 'resolved'.

Once again, just PUT THE FILE WHERE THE USER TOLD YOU TO PUT IT and all
this goes away (or at least it's the user's fault if they run out of
space, not yours).

The speed up in downloads you are achieving is trivial compared to the
problems and confusion you are causing.
 

Comment 3

17 years ago
Bob, try a newer build. I think this has been fixed since 09/04

Comment 4

17 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.