Closed Bug 989714 Opened 6 years ago Closed 6 years ago

[Tarako][WIFI][Internet sharing] Unable to establish wifi connect after wifi-hotspot enabled.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 989717

People

(Reporter: bli, Assigned: vchang)

Details

Attachments

(1 file)

Attached file AP_WIFI.log
Environment:
------------------
Gaia 14ef4fcdf9199f04f7678755c917dc77f51e13ba
Gecko https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/b574a7967338
BuildID 20140329004002
Version 28.1


Steps to reproduce:
----------------------
1. Launch settings
2. Select "Internet sharing"
3. Enable "Wifi-hotspot"
4. Notice that "Wi-Fi" is disabled on the status bar
5. Click "Back" button
6. From Settings menu Click on "Wi-fi"
7. Enable "wifi"

Actual results:
-----------------------
1. Wifi connection cannot be established, and it keeps searching available network.
2. Wifi-hotspot isn't disabled, and the icon is still shown in the status bar.


Additional info:
-----------------------
Attached the adb log.
blocking-b2g: --- → 1.3T?
Flags: needinfo?(vchang)
Hi! Vincent,

other case for you. Thanks

--
Keven
(In reply to Joe Cheng [:jcheng] from comment #2)
> is this a dup of https://bugzilla.mozilla.org/show_bug.cgi?id=989717? thanks
Hi Joe,
I don't think this is a dup of 989717.

The phenomenon of bug #989717 is like following:
After you disable wifi, you can not enable it agian, because the button turns grey, and no response when you tap on it.

The phenomenon of this bug is like this:
After you enable wifi, it keeps searching available network, and unable to connect to the ap.
I wonder if setting app disables WIFI hotspot before enabling WIFI.
Flags: needinfo?(ehung)
Assignee: nobody → vchang
Flags: needinfo?(vchang)
This is correct behavior.   If you are using the device as a wifi hotspot (sending), you'd be connected via SIM Cellular and Data.   If you tried to use both Wifi hotspot (sending), and connect to network via wifi (receiving) that shouldn't work.
Status: NEW → RESOLVED
blocking-b2g: 1.3T? → ---
Closed: 6 years ago
Resolution: --- → INVALID
Flags: needinfo?(ehung)
(In reply to John Hammink from comment #5)
The bug should be whether hotspot mode need to be automatically turned off when user enable wifi mode. What is our user story for this use scenario? I had tried other phones before I ni? evenly. Other phones turn off hotspot mode when wifi mode is turned on.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 989717
You need to log in before you can comment on or make changes to this bug.