Closed Bug 989830 Opened 6 years ago Closed 6 years ago

[MCB] WineHQ's search is broken

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: strugee, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [mcb] [country-us])

+++ This bug was initially created as a clone of Bug #975929 +++

Steps to Reproduce:
1. Have the Mixed Content Blocker turned on
2. Have HTTPS Everywhere[1] installed and turned on
3. Either load https://www.winehq.org/search?cx=partner-pub-0971840239976722%3Aw9sqbcsxtyf&cof=FORID%3A10&ie=UTF-8&q=test&siteurl=appdb.winehq.org%2F&ref=&ss=296j41280j4 or visit https://appdb.winehq.org, then search for something in the search box on the upper-right of the page

Expected results:
Search results should display

Actual results:
The search results (or whatever loads the search results) triggers a Mixed Content Blocker violation and never displays.

Obviously, this issue is triggered by HTTPS Everywhere. However, eventually Wine is probably going to turn on HTTPS by default for these things, and it will break in all browser configurations, not just those with HTTPS Everywhere. Better to fix it now than later.

 [1]: https://www.eff.org/https-everywhere
Blocks: 844556
Confirming for Aurora 30 (no HTTPS Everywhere and with) and IE11 for the given HTTPS URL.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This seems to be solved. No message in the console.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Whiteboard: [mcb] [country-us]
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.